All Apps and Add-ons

qualys_kb_lookup is suddenly empty

New Member


suddenly the qualys_kb_lookup is empty and

| inputlookup qualys_kb_lookup

does not return any results anymore.

Any ideas on how I can analyze/fix the issue? I am new to Splunk 😉


0 Karma


As stated on Splunkbase by the author in the release note:

"Error faced while parsing knowledgebase API response when CVSS data is missing in the response."

Updating the TA to the latest version should resolve this issue.

0 Karma

New Member

Data input is configured

knowledge_base  30 * * * *  1999-01-01T00:00:00Z
0 Karma

New Member

solved this issue, but still have no clue why this happend from one day to the other

/opt/splunk/etc/apps/TA-QualysCloudPlatform /opt/splunk/bin/splunk cmd python ./bin/ -k -s [apiserver] -u [user] -p [password]

Error message indicated an issue with CVSS VECTOR helped here

0 Karma


We ran into the same issue and the issue was that Qualys recently updated their API to include a new field called CVSS_VECTOR_STRING. This was conflicting with the script in the TA and backing up and editing the TA worked for us.

Two solutions to this,

1)Follow the fix in the above link


2)Upgrade to the new 1.4.0 TA which comes with the fix and was released on Jan 28th 2019.

Looks like you've addressed the issue but just wanted to share the background and the knowledge of the new version of TA

0 Karma
Get Updates on the Splunk Community!

Infographic provides the TL;DR for the 2023 Splunk Career Impact Report

We’ve been shouting it from the rooftops! The findings from the 2023 Splunk Career Impact Report showing that ...

Splunk Lantern | Getting Started with Edge Processor, Machine Learning Toolkit ...

Splunk Lantern is Splunk’s customer success center that provides advice from Splunk experts on valuable data ...

Enterprise Security Content Update (ESCU) | New Releases

In the last month, the Splunk Threat Research Team (STRT) has had 2 releases of new security content via the ...