All Apps and Add-ons

odbc connector

Engager

I am getting an error message when I attempt to connect to splunk via the odbc driver from excel. [60] Unexpected response from server. Verify the server URL. Error parsing JSON: Expect either an object or array at root

I am using the 32bit version.

We have splunk enterprise installed. In the host box I am using the server path to one of the search heads. I have the verify ssl certificate unchecked; And in the server.conf the requireClientSSL... is not in there and the default of false should be applied.

Tags (3)
1 Solution

Splunk Employee
Splunk Employee

Hi,
Please do the following -
1. Open 32-bit ODBC administrator panel.
2. Click the System DSN tab; select the Splunk DSN and click configure.
3. What does your Server URL setting have ? It should be set like this - https://:; e.g https://10.225.196.112:8089
4. Make sure that the mgmt port on your Splunk search head is not being blocked by your firewall.

View solution in original post

0 Karma

Engager

It took me days but I found the solution. Version 2.1.0 doesn't work with Splunk 6.4.1 You have to use version 2.0.0 You can download it here : https://splunkbase.splunk.com/app/1606/release/2.0.0/agree/

0 Karma

Engager

It took me days but I found the solution. Version 2.1.0 doesn't work with Splunk 6.4.1 You have to use version 2.0.0 You can download it here : https://splunkbase.splunk.com/app/1606/release/2.0.0/agree/

0 Karma

Splunk Employee
Splunk Employee

Hi,
Please do the following -
1. Open 32-bit ODBC administrator panel.
2. Click the System DSN tab; select the Splunk DSN and click configure.
3. What does your Server URL setting have ? It should be set like this - https://:; e.g https://10.225.196.112:8089
4. Make sure that the mgmt port on your Splunk search head is not being blocked by your firewall.

View solution in original post

0 Karma

Engager

cool this was the answer I needed; I think it was I was on the wrong port.

0 Karma