All Apps and Add-ons
Highlighted

login failed

Explorer

I am trying to install splunk add-on and when i am running the setup.sh command by using
export SPLUNKHOME=/opt/splunk
cd $SPLUNK
HOME/etc/apps/SplunkTAnix
. ./setup.sh
I get
Login failed
Login Failed
so i seen some document and answer and with reference to that i get to know that i have to use
$SPLUNKHOME/bin/splunk cmd $SPLUNKHOME/etc/apps/SplunkTAnix/bin/setup.sh
but it also give me error Syntax error: "(" unexpected i stucked here for so long and cant figure out the way out of it
So tell me that am i doing things right and what else i have to do to configure it.

0 Karma
Highlighted

Re: login failed

Super Champion
0 Karma
Highlighted

Re: login failed

Explorer

Yes i referd this docs
when i used
$SPLUNKHOME/bin/splunk cmd $SPLUNKHOME/etc/apps/SplunkTAnix/bin/setup.sh
above command i got error Syntax error: "(" unexpected.

0 Karma
Highlighted

Re: login failed

Explorer

It worked but when I run that command I menu open and I select manage *nix inputs and the I opted for enable all inputs it give me message enable failed.
What is the problem what should be done to solve this issue?

0 Karma
Highlighted

Re: login failed

Communicator

I don't have this app, but you could try, before you run setup.sh, that you are logged in into splunk.
You could do that this way

# splunk login -auth ${logname}:${mypwd}

On a Test system you could take the admin account, on a productive system you better take a low priv user before using an admin user.

To logout on the shell use this

# splunk logout
0 Karma
Highlighted

Re: login failed

Explorer

hey I solved that problem but after login
menu open and I select 2 option
manage nix inputs
and again new menu open then I opted for 2 option
enable all inputs
it give me message enable failed*.
What is the problem what should be done to solve this issue?

0 Karma