All Apps and Add-ons

Will IMAP Mailbox work for Splunk 6.3?

loje
New Member

I have installed the IMAP Mailbox application in version 6.2.x and everything works fine.
After I have updated to 6.3.0, the IMAP application stopped working.

When I try to run get_imap_email.py, it gives:

DEBUG:root:EOF occurred in violation of protocol (_ssl.c:595)
Traceback (most recent call last):
  File "get_imap_email.py", line 331, in getMail
    M = imaplib.IMAP4_SSL(self.server,int(self.port))
  File "/home/splunk/lib/python2.7/imaplib.py", line 1165, in __init__
    IMAP4.__init__(self, host, port)
  File "/home/splunk/lib/python2.7/imaplib.py", line 172, in __init__
    self.open(host, port)
  File "/home/splunk/lib/python2.7/imaplib.py", line 1177, in open
    self.sslobj = ssl.wrap_socket(self.sock, self.keyfile, self.certfile)
  File "/home/splunk/lib/python2.7/ssl.py", line 891, in wrap_socket
    ciphers=ciphers)
  File "/home/splunk/lib/python2.7/ssl.py", line 566, in __init__
    self.do_handshake()
  File "/home/splunk/lib/python2.7/ssl.py", line 788, in do_handshake
    self._sslobj.do_handshake()
SSLEOFError: EOF occurred in violation of protocol (_ssl.c:595)
None
Traceback (most recent call last):
  File "get_imap_email.py", line 717, in <module>
    parseArgs()
  File "get_imap_email.py", line 709, in parseArgs
    imapProc.getMail()
  File "get_imap_email.py", line 345, in getMail
    raise LoginError('Could not log into server: %s with password provided' % self.server)
__main__.LoginError: Could not log into server:   with password provided
I have another server with same configuration and Splunk 6.2.
And everything works fine..

Is there any problems for IMAP mailbox running on Splunk 6.3?

0 Karma

ragingwire
Path Finder

I have upgraded my system to 6.3.0. I use SSL IMAP to gmail and am getting no errors. Is the server you are connecting too have a self-signed cert? Is it running SSL v1 or v2 or TLS?

Appears there is a python ssl bug. https://stackoverflow.com/questions/14102416/python-requests-requests-exceptions-sslerror-errno-8-ss...

Since I can't reproduce, I'm not sure if the suggested fixes will help.

0 Karma

loje
New Member

it works fine now. Thanks for your help and solution!

0 Karma

dfronck
Communicator

You should mark this as answered.

0 Karma

ppablo
Retired

Hi @loje

Looking at the app's page on Splunkbase (https://splunkbase.splunk.com/app/1739/ ), Splunk 6.3 is not listed as one of the supported versions. Only Splunk 6.0, 6.1, and 6.2 are shown. Hopefully the developer of the app will answer/comment here with an update for you if there are plans to make it compatible with 6.3.

0 Karma
Get Updates on the Splunk Community!

.conf24 | Day 0

Hello Splunk Community! My name is Chris, and I'm based in Canberra, Australia's capital, and I travelled for ...

Enhance Security Visibility with Splunk Enterprise Security 7.1 through Threat ...

 (view in My Videos)Struggling with alert fatigue, lack of context, and prioritization around security ...

Troubleshooting the OpenTelemetry Collector

  In this tech talk, you’ll learn how to troubleshoot the OpenTelemetry collector - from checking the ...