All Apps and Add-ons
Highlighted

Why is the Supporting Add-on ldapsearch working with OpenLDAP but sending incomplete DN?

New Member

Hello Splunkers,

I use SA-ldapsearch to get data from openldap server, employee information, etc...
It was working fine but now it looks like the addon sent incomplete DN, just the first letter.

 Feb  5 16:31:51 slapd[98008]: conn=1298 fd=120 ACCEPT from IP=***.***.***:47803 (IP=*.*.*.*:636)
 Feb  5 16:31:51 slapd[98008]: conn=1298 fd=120 TLS established tls_ssf=256 ssf=256
 Feb  5 16:31:51 slapd[98008]: conn=1298 op=0 SRCH base="" scope=0 deref=3 filter="(objectClass=*)"
 Feb  5 16:31:51 slapd[98008]: conn=1298 op=0 SRCH attr=* +
 Feb  5 16:31:51 slapd[98008]: conn=1298 op=0 SEARCH RESULT tag=101 err=0 nentries=1 text=
 Feb  5 16:31:51 slapd[98008]: conn=1298 op=1 SRCH base="cn=Subschema" scope=0 deref=3 filter="(objectClass=subschema)"
 Feb  5 16:31:51 slapd[98008]: conn=1298 op=1 SRCH attr=objectClasses attributeTypes ldapSyntaxes matchingRules matchingRuleUse dITContentRules dITStructureRules nameForms createTimestamp modifyTimestamp * +
 Feb  5 16:31:51 slapd[98008]: conn=1298 op=1 SEARCH RESULT tag=101 err=0 nentries=1 text=
 Feb  5 16:31:51 slapd[98008]: conn=1298 op=2 BIND dn="cn=*,ou=Services,dc=*,dc=*" method=128
 Feb  5 16:31:51 slapd[98008]: conn=1298 op=2 BIND dn="cn=*,ou=Services,dc=*,dc=*" mech=SIMPLE ssf=0
 Feb  5 16:31:51 slapd[98008]: conn=1298 op=2 RESULT tag=97 err=0 text=
 Feb  5 16:31:51 slapd[98008]: conn=1298 op=3 SRCH base="" scope=0 deref=3 filter="(objectClass=*)"
 Feb  5 16:31:51 slapd[98008]: conn=1298 op=3 SRCH attr=* +
 Feb  5 16:31:51 slapd[98008]: conn=1298 op=3 SEARCH RESULT tag=101 err=0 nentries=1 text=
 Feb  5 16:31:51 slapd[98008]: conn=1298 op=4 do_search: invalid dn: "c"
 Feb  5 16:31:51 slapd[98008]: conn=1298 op=4 SEARCH RESULT tag=101 err=34 nentries=0 text=invalid DN
 Feb  5 16:31:51 dhadlx135 slapd[98008]: conn=1298 fd=120 closed (connection lost) 

Thank you for your help.

0 Karma