All Apps and Add-ons

Why am I getting error "archive contains more than one immediate subdirectory" installing Splunk App for NetApp data ONTAP 2.1.4?

Engager

Hello,

I tried to install the Splunk App for NetApp Data ONTAP 2.1.4 on Splunk 6.4.4 version.
But I got message:

Invalid app contents: archive contains more than one immediate subdirectory: and SA-Hydra

How can I fix it??

Motivator

Make sure your archive has parent and child directories

Example: (Content of xyz.tgz or xyz.zip)

 <app_name>
      |___ default
      |___ metadata
      |___ local
0 Karma

Contributor

You can't install this app via the GUI as the tgz file contains multiple apps (dependencies). You'll need to extract the tgz file within /opt/splunk/etc/apps (if not using a cluster) and restart splunk. However, since version 2.1.5, the search head app is now stand alone and can be installed via the GUI. But the Add-on still contains multiple apps and requires manual unpacking.

Communicator

Same issue was with "Splunk Add-on for VMware". Solved using above method. Thanks

0 Karma

Motivator

Same issue for Exchange add-on for Splunk 7.2. Same fix. Thanks.

0 Karma
State of Splunk Careers

Access the Splunk Careers Report to see real data that shows how Splunk mastery increases your value and job satisfaction.

Find out what your skills are worth!