All Apps and Add-ons

Why am I getting a Read Timeout error in my browser when trying to save settings for the App for Twitter Data?

New Member

I've installed the twitter app as instructed. The app then requests the settings from twitter and these all work as I have tested them with the REST API. After clicking save on the twitter app, the browser spins and then states error Read Timeout.

This is what the web pages shows:

This XML file does not appear to have any style information associated with it. The document tree is shown below.

From the log:

02-20-2015 11:47:40.517 -0500 ERROR HttpClientRequest - HTTP client error: Read Timeout (while accessing
Tags (1)
0 Karma

New Member

I had the same issue with my local installation of Splunk Enterprise 6.4.1 x64 running on Windows 10 x64.

The problem occurred when the twitter2 app reloads the page:

WARN  LocalAppsAdminHandler - User 'admin' triggered the '_reload' action on app 'twitter2', and the following objects required a restart: restart_on_install
ERROR HttpClientRequest - HTTP client error: Read Timeout (while accessing

What worked for me was to change the default appServerPorts in Splunk\etc\system\default\web.conf from 8065 to 0.

# list of ports to start python application servers on (although usually
# one port is enough)  Set to 0 to instead run the application server
# directly as the web front end on 'httpport', separate from splunkd.
appServerPorts = 0

Hope it helps.

0 Karma


Try to increase the sessionTimeOut in web.conf
Default is of 30 sec.
Try it to increase to 60 sec or accordingly. In my case it worked fine.

0 Karma
Did you miss .conf21 Virtual?

Good news! The event's keynotes and many of its breakout sessions are now available online, and still totally FREE!