All Apps and Add-ons

Website Monitoring: Why are we getting "duplicate module dir name..." warnings in logs and not getting any data?

cdsailer_bb
New Member

I've got the app installed and configured, Splunk has been restarted, but I am not getting any data. The troubleshooting tips don't return anything useful, but this does stand out in the logs:

2016-10-12 20:27:49,013 INFO    [57fe9cc5027fea447e6450] decorators:362 - require_login - no splunkd sessionKey variable set; cherrypy_session=1acc86313a26f59cc5413282ee5cacb023d0aa02 request_path=/en-US/
app/website_monitoring/status_overview
2016-10-12 20:27:55,046 WARNING [57fe9ccaf37fea40766690] apps:91 - Duplicate module dir name 'admin' between apps 'Splunk_TA_aws' and 'website_monitoring', will refer to module dir in 'Splunk_TA_aws

Any suggestions on where to go from here?
Thanks in advance!!

0 Karma
1 Solution

LukeMurphey
Champion

I tried to reproduce this by installing both Website Monitoring and TA AWS. I do see the logs about you see but the app works fine.

Are you saying that you have Website Monitoring inputs already created but they aren't creating events? I'm assuming this is the case, but I wanted to make sure.

Would it be possible to disable AWS temporarily to see if Website Monitoring works? That would at least isolate the issue to an incompatibility between these two apps.

Alternatively, you could let me know what other apps you have installed and I could try reproducing the issue with those other apps.

View solution in original post

0 Karma

LukeMurphey
Champion

I tried to reproduce this by installing both Website Monitoring and TA AWS. I do see the logs about you see but the app works fine.

Are you saying that you have Website Monitoring inputs already created but they aren't creating events? I'm assuming this is the case, but I wanted to make sure.

Would it be possible to disable AWS temporarily to see if Website Monitoring works? That would at least isolate the issue to an incompatibility between these two apps.

Alternatively, you could let me know what other apps you have installed and I could try reproducing the issue with those other apps.

View solution in original post

0 Karma

cdsailer_bb
New Member

Thanks for the prompt reply Luke, and I apologize for the delay in my response. I got half way through a reply earlier then got distracted and sidetracked.

I think the errors I mentioned were just a red herring, nothing to do with my reporting issue. Earlier this morning I noticed a new error on the website monitor app page pointing to comm errors on the indexers ( I don't have the exact error available but I can post it tomorrow ). From there I decided to install the app on the indexer ( had only been installed on the search head ), once I did that everything started working. I should have provided you a brief overview of our setup in my original question, my bad. I'm pretty new to Splunk, so drinking from the firehose right now.

Again, I appreciate you prompt reply and your time. Hopefully someday I can make some positive contributions to the group. 🙂

0 Karma

cdsailer_bb
New Member

oh, didn't answer your question from above.... 😞

I had configured Website Monitoring Inputs, but was not getting any events, you assumed correctly.

0 Karma

LukeMurphey
Champion

Glad you got it working. I'll update the docs to make that clearer in the future.

0 Karma

LukeMurphey
Champion

I'm testing this now to see if I can reproduce it.

0 Karma
Take the 2021 Splunk Career Survey

Help us learn about how Splunk has
impacted your career by taking the 2021 Splunk Career Survey.

Earn $50 in Amazon cash!