All Apps and Add-ons

Using splunk db connect to send data from db, which is timestamped in GMT, set user preference to EST in portal, data can not be found using last 4 hours, because data is in the future

rileyken2
Path Finder

Using splunk db connect to send data from db, which is timestamped in GMT, set user preference to EST in portal, data can not be found using last 4 hours, because data is in the future

Only workaround is to select 'all time" which is not great

0 Karma
1 Solution

rileyken2
Path Finder
0 Karma

rileyken2
Path Finder

typically I just use a known sourcetype like "access_combined", but in this case the db connect handles that set up, not sure what it is and there is nothing in the application installation docs that give details on how to configure.

I did try passing a arg to the JVM on start up, setting the TZ to UTC.. did not see to matter

0 Karma

rileyken2
Path Finder

on the heavy forwarder running the db connect or the indexer (all in one)?

the answer in both cases is default, I have not tried that

0 Karma

richgalloway
SplunkTrust
SplunkTrust

So that's your first problem. Every input should have a sourcetype defined and that definition should include, at a mininum, TIME_PREFIX, TIME_FORMAT, MAX_TIMESTAMP_LOOKAHEAD,LINE_BREAKER, andTRUNCATE`.

---
If this reply helps you, Karma would be appreciated.
0 Karma

richgalloway
SplunkTrust
SplunkTrust

What are the props.conf settings for the sourcetype?

---
If this reply helps you, Karma would be appreciated.
0 Karma
Get Updates on the Splunk Community!

.conf24 | Day 0

Hello Splunk Community! My name is Chris, and I'm based in Canberra, Australia's capital, and I travelled for ...

Enhance Security Visibility with Splunk Enterprise Security 7.1 through Threat ...

(view in My Videos)Struggling with alert fatigue, lack of context, and prioritization around security ...

Troubleshooting the OpenTelemetry Collector

  In this tech talk, you’ll learn how to troubleshoot the OpenTelemetry collector - from checking the ...