All Apps and Add-ons

Universal Forwarder issues following TA error message in log.

yjkim3830
New Member

How can I solve the about error messages on universal forwarder?

[Error Message]
01-23-2013 10:24:49.191 +0900 INFO ExecProcessor - Ran script: C:\Windows\System32\WindowsPowerShell\v1.0\powershell.exe -command " &'C:\Program Files\SplunkUniversalForwarder\etc\apps\TA-HyperV08-Server\bin\powershell\GetVMDetail.ps1'" -index servervirt, took 889.2 milliseconds to run, 0 bytes read, exited with code 1
01-23-2013 10:24:55.915 +0900 ERROR ExecProcessor - message from "C:\Windows\System32\WindowsPowerShell\v1.0\powershell.exe -command " &'C:\Program Files\SplunkUniversalForwarder\etc\apps\TA-HyperV08-Server\bin\powershell\GetVMHostDetail.ps1'" -index servervirt" File C:\Program Files\SplunkUniversalForwarder\etc\apps\TA-HyperV08-Server\bin\
01-23-2013 10:24:55.915 +0900 ERROR ExecProcessor - message from "C:\Windows\System32\WindowsPowerShell\v1.0\powershell.exe -command " &'C:\Program Files\SplunkUniversalForwarder\etc\apps\TA-HyperV08-Server\bin\powershell\GetVMHostDetail.ps1'" -index servervirt" powershell\GetVMHostDetail.ps1 cannot be loaded because the execution of script
01-23-2013 10:24:55.915 +0900 ERROR ExecProcessor - message from "C:\Windows\System32\WindowsPowerShell\v1.0\powershell.exe -command " &'C:\Program Files\SplunkUniversalForwarder\etc\apps\TA-HyperV08-Server\bin\powershell\GetVMHostDetail.ps1'" -index servervirt" s is disabled on this system. Please see "get-help about_signing" for more deta
01-23-2013 10:24:55.915 +0900 ERROR ExecProcessor - message from "C:\Windows\System32\WindowsPowerShell\v1.0\powershell.exe -command " &'C:\Program Files\SplunkUniversalForwarder\etc\apps\TA-HyperV08-Server\bin\powershell\GetVMHostDetail.ps1'" -index servervirt" ils.
01-23-2013 10:24:55.915 +0900 ERROR ExecProcessor - message from "C:\Windows\System32\WindowsPowerShell\v1.0\powershell.exe -command " &'C:\Program Files\SplunkUniversalForwarder\etc\apps\TA-HyperV08-Server\bin\powershell\GetVMHostDetail.ps1'" -index servervirt" At line:1 char:3
01-23-2013 10:24:55.915 +0900 ERROR ExecProcessor - message from "C:\Windows\System32\WindowsPowerShell\v1.0\powershell.exe -command " &'C:\Program Files\SplunkUniversalForwarder\etc\apps\TA-HyperV08-Server\bin\powershell\GetVMHostDetail.ps1'" -index servervirt" + & <<<< 'C:\Program Files\SplunkUniversalForwarder\etc\apps\TA-HyperV08-Serve
01-23-2013 10:24:55.915 +0900 ERROR ExecProcessor - message from "C:\Windows\System32\WindowsPowerShell\v1.0\powershell.exe -command " &'C:\Program Files\SplunkUniversalForwarder\etc\apps\TA-HyperV08-Server\bin\powershell\GetVMHostDetail.ps1'" -index servervirt" r\bin\powershell\GetVMHostDetail.ps1' -index servervirt
01-23-2013 10:24:55.915 +0900 ERROR ExecProcessor - message from "C:\Windows\System32\WindowsPowerShell\v1.0\powershell.exe -command " &'C:\Program Files\SplunkUniversalForwarder\etc\apps\TA-HyperV08-Server\bin\powershell\GetVMHostDetail.ps1'" -index servervirt" + CategoryInfo : NotSpecified: (:) [], PSSecurityException
01-23-2013 10:24:55.915 +0900 ERROR ExecProcessor - message from "C:\Windows\System32\WindowsPowerShell\v1.0\powershell.exe -command " &'C:\Program Files\SplunkUniversalForwarder\etc\apps\TA-HyperV08-Server\bin\powershell\GetVMHostDetail.ps1'" -index servervirt" + FullyQualifiedErrorId : RuntimeException
01-23-2013 10:24:55.915 +0900 ERROR ExecProcessor - message from "C:\Windows\System32\WindowsPowerShell\v1.0\powershell.exe -command " &'C:\Program Files\SplunkUniversalForwarder\etc\apps\TA-HyperV08-Server\bin\powershell\GetVMHostDetail.ps1'" -index servervirt"

0 Karma
1 Solution

jconger
Splunk Employee
Splunk Employee

Within all that verbiage is a message (across several lines) that states:

"... cannot be loaded because the execution of scripts is disabled on this system. Please see "get-help about_signing" for more details"

This means that you need to set your PowerShell execution policy on your Hyper-V server. Execute the following:

Set-ExecutionPolicy RemoteSigned.

View solution in original post

0 Karma

jconger
Splunk Employee
Splunk Employee

Within all that verbiage is a message (across several lines) that states:

"... cannot be loaded because the execution of scripts is disabled on this system. Please see "get-help about_signing" for more details"

This means that you need to set your PowerShell execution policy on your Hyper-V server. Execute the following:

Set-ExecutionPolicy RemoteSigned.

0 Karma

yjkim3830
New Member

Thank you very much for your help.

0 Karma
Get Updates on the Splunk Community!

Splunk Community Platform Survey

Hey Splunk Community, Starting today, the community platform may prompt you to participate in a survey. The ...

Observability Highlights | November 2022 Newsletter

 November 2022Observability CloudEnd Of Support Extension for SignalFx Smart AgentSplunk is extending the End ...

Avoid Certificate Expiry Issues in Splunk Enterprise with Certificate Assist

This blog post is part 2 of 4 of a series on Splunk Assist. Click the links below to see the other ...