All Apps and Add-ons

Timechart displaying undefined NaN in the left corner

tkhatri
Explorer

I am creating a single series timechart that does a count of ids and then I am using | appendpipe [stats count | where count=0] to display 0 instead of 'No results found'.

The timechart shows up right but in addition also shows undefined NaN like shown below. Can anyone please help suggest why is it happening and how to get rid of it.

tkhatri_1-1599775459636.png

Thanks.

 

Labels (2)
0 Karma
1 Solution

renjith_nair
Legend

Does this work for you ?

your search |appendpipe [|makeresults]

 

---
What goes around comes around. If it helps, hit it with Karma 🙂

View solution in original post

renjith_nair
Legend

Does this work for you ?

your search |appendpipe [|makeresults]

 

---
What goes around comes around. If it helps, hit it with Karma 🙂

miguel1423
Explorer

Hi

I've the same issue, could you show me where do you place the "makeresult" please ?

 

 | appendpipe [stats count | where count=0]

 

Regards,

0 Karma

tkhatri
Explorer

Try this: 

| appendpipe [|where count=0
| makeresults]|

miguel1423
Explorer

thx 😃

0 Karma

tkhatri
Explorer

It worked. Thank you Renjith.

0 Karma
Get Updates on the Splunk Community!

Detecting Remote Code Executions With the Splunk Threat Research Team

WATCH NOWRemote code execution (RCE) vulnerabilities pose a significant risk to organizations. If exploited, ...

Enter the Splunk Community Dashboard Challenge for Your Chance to Win!

The Splunk Community Dashboard Challenge is underway! This is your chance to showcase your skills in creating ...

.conf24 | Session Scheduler is Live!!

.conf24 is happening June 11 - 14 in Las Vegas, and we are thrilled to announce that the conference catalog ...