All Apps and Add-ons

Talk to Splunk with Amazon Alexa not starting with error "Unable to initialize modular input "alexa"... Introspecting scheme=alexa: script running failed"

keilinw
New Member

Upon a brand new installation as root and starting as root, I get the following error message: Any ideas?

Unable to initialize modular input "alexa" defined inside the app "alexa": Introspecting scheme=alexa: script running failed (exited with code 1).
0 Karma

antlefebvre
Communicator

Be sure you have Java 8+ installed on the system. I installed Java 9 (assuming this fulfilled the 8+ requirement) and got the same error you are seeing. When I backed the Java version down to 8 the error went away and I was able to see the Alexa input.

0 Karma

Damien_Dallimor
Ultra Champion

Have you worked through the troubleshooting steps in the docs

0 Karma
Get Updates on the Splunk Community!

What's New in Splunk Cloud Platform 9.2.2403?

Hi Splunky people! We are excited to share the newest updates in Splunk Cloud Platform 9.2.2403! Analysts can ...

Stay Connected: Your Guide to July and August Tech Talks, Office Hours, and Webinars!

Dive into our sizzling summer lineup for July and August Community Office Hours and Tech Talks. Scroll down to ...

Edge Processor Scaling, Energy & Manufacturing Use Cases, and More New Articles on ...

Splunk Lantern is a Splunk customer success center that provides advice from Splunk experts on valuable data ...