All Apps and Add-ons

Talk to Splunk with Amazon Alexa: How to verify the app is listening on port 443?

keilinw
New Member

Inspired by this blog:
http://blogs.splunk.com/2016/09/08/talk-to-splunk-with-amazon-alexa/

I followed the instructions found here:
https://github.com/damiendallimore/SplunkModularInputsJavaFramework/blob/master/alexa/docs/README.md

I've gotten most everything set up and working correctly. However, I don't see where the Splunk Alexa App is listening on any port:

sudo netstat -plnt

... all the normal stuff plus:

tcp        0      0 0.0.0.0:8000                0.0.0.0:*                   LISTEN      4468/splunkd

When configuring the Alexa Stanza, I've tried multiple variations of the endpoint setting. IE.

localhost/alexa
https://localhost/alexa
localhost:443/alexa
mydomain/alexa
https://mydomain/alexa
mydomain:443/alexa

I also have tried restarting the server as well as the Splunk App separately.

Yet no matter what I do, I never see anything on the server actually listening on port 443.

Any ideas?

0 Karma

nickhills
Ultra Champion

I also had this, but realised i dint have java 8 installed. Once I corrected that, and restarted and it started listening.

netstat -plnt |grep 443

tcp        0      0 :::443                      :::*                        LISTEN      27185/java    
If my comment helps, please give it a thumbs up!
0 Karma

Damien_Dallimor
Ultra Champion

Does the user you are running Splunk as have permission to open ports <1024 ?

As written in the docs

0 Karma
.conf21 Now Fully Virtual!
Register for FREE Today!

We've made .conf21 totally virtual and totally FREE! Our completely online experience will run from 10/19 through 10/20 with some additional events, too!