All Apps and Add-ons

TA-uas_parser: Why am I getting an error trying to update cache?


Hi there,

I tried the command below as suggested from the documentation page, however, an error was prompted. Any ideas?
Thank you!

D:\Program Files\Splunk\etc\apps\TA-uas_parser\bin>"D:\Program Files\Splunk\"bin
\splunk cmd python
Traceback (most recent call last):
  File "", line 4, in 
    results = uas_parser.updateData()
  File "D:\Program Files\Splunk\etc\apps\TA-uas_parser\bin\", line 2
65, in updateData
    raise UASException("Failed to get version of lastest data")
uasparser.UASException: Failed to get version of lastest data
Tags (1)


The data source in question went subscription based and changed the URL.

Update_cache looks for a version number at: however, that now returns:

ERROR 404 - These data are not longer available on, please look at

Once you purchase a subscription, you would need to modify the URLs in the file according to:


Were you able to resolve this? I am on Linux but running into the same problem. Thanks in advance.

0 Karma

New Member

I am also getting the same error. Any one resolved this issue?

0 Karma


As a follow up, in my case, my splunk instance is actively accumulating log data in real time. Might this be part of the problem?

0 Karma
.conf21 Now Fully Virtual!
Register for FREE Today!

We've made .conf21 totally virtual and totally FREE! Our completely online experience will run from 10/19 through 10/20 with some additional events, too!