All Apps and Add-ons

Splunk Support for Active Directory: Why can I not search from the root of the domain after upgrade to Splunk 6.2?

Path Finder

We are utilizing the Splunk Supporting Add-on for Active Directory version 2.0 and we are no longer able to search from the root of our domain. If I run the exact same search and point it to an OU below the root it will work without any issues. If I run the test connection on the configuration screen, which searches at the root, it works just fine.

This search works.
| ldapsearch basedn="OU=MyOU,DC=my,DC=domain" search="(objectClass=user)" attrs="sAMAccountName,displayName,Title,distinguishedName"

This one does not work.
| ldapsearch basedn="DC=my,DC=domain" search="(objectClass=user)" attrs="sAMAccountName,displayName,Title,distinguishedName"

0 Karma

Splunk Employee
Splunk Employee

Please post your ldap.conf for a full answer.

0 Karma
Did you miss .conf21 Virtual?

Good news! The event's keynotes and many of its breakout sessions are now available online, and still totally FREE!