All Apps and Add-ons

Splunk MINT: How to resolve "Error:(38, 13) Failed to resolve: com.splunk:mint-android-sdk:5.2.0" after using Android Gradle plugin 2.2.3?

TheArrival
New Member

Hello Support and Community,

i'm trying to setup the Splunk Mint SDK for Android using the Gradle plugin. I added the following link to my Gradle file:

buildscript {
    repositories {
        maven {
            url uri('mint-plugin-repo-5.2.0')
        }
    }
}

dependencies {
    compile 'com.splunk:mint-android-sdk:5.2.0'
}

when trying to sync the Gradle, i get the following error:

Error:(38, 13) Failed to resolve: com.splunk:mint-android-sdk:5.2.0

Thanks in advance
Marcus

Tags (3)
0 Karma

croyal_splunk
Splunk Employee
Splunk Employee

Are you using Android Studio 2.2?

Requirements:

Android Studio version 2.1.x. Note that Android Studio 2.2 or later is not supported.

You have a couple of options: 1) use the SDK as library without our Gradle Plugin or 2) wait until Android SDK 5.2.1, which will include Android Studio 2.2 support.

0 Karma
Did you miss .conf21 Virtual?

Good news! The event's keynotes and many of its breakout sessions are now available online, and still totally FREE!