All Apps and Add-ons

Splunk DB Connect: How to resolve "Unable to establish a secure connection to DBX Server" error after changing port 9998 to a different port?

sakeebhossain
Explorer

I am trying to setup Splunk on a Linux machine, along the Splunk DB Connect add-on. However, when I open the add-on, I receive the following error:

"Can not communicate with task server, please check your settings."

Checking my log files, it seems that the port 9998 (the one set by default) is already in use. I tried changing the port to something else, as suggested by some answers to similar problems but then I receive an additional error:

"Unable to establish a secure connection to DBX Server, please make sure it is started and listening on 9998 port or consult documentation for details"

How can I resolve this?

0 Karma
1 Solution

sakeebhossain
Explorer

So I've managed to resolve it! Turns out all I needed to do was to navigate to Configuration > Settings > General and ALSO change the task server port to the new one in the "JVM Options" and "Task Server Port" boxes.

View solution in original post

sakeebhossain
Explorer

So I've managed to resolve it! Turns out all I needed to do was to navigate to Configuration > Settings > General and ALSO change the task server port to the new one in the "JVM Options" and "Task Server Port" boxes.

View solution in original post

chrisfrigo
Path Finder

changed to a different port other than port 9998, e.g. 9995 and works fine.

adonio
SplunkTrust
SplunkTrust
0 Karma

sakeebhossain
Explorer

Hi adonio, I already tried this solution, (changing port to 1025 in dbx_task_server.yml) but I still get the second error I mentioned: "Unable to establish a secure connection to DBX Server, please make sure it is started and listening on 9998 port or consult documentation for details"

0 Karma
Register for .conf21 Now! Go Vegas or Go Virtual!

How will you .conf21? You decide! Go in-person in Las Vegas, 10/18-10/21, or go online with .conf21 Virtual, 10/19-10/20.