All Apps and Add-ons

Splunk DB Connect 3.6.0 and RHEL 8

ckeller2791
Explorer

We have migrated from Splunk 8.0 running on Windows Server 2016 to  Splunk 8.2.1 running on RHEL 8.  Trying to get Splunk DB Connect working again. On Windows it ran without incident, however on RHEL it continues to "Failed to restart task server". So far I have done the following to troubleshoot.

  1. Installed Oracle Java SDK 1.8.301
  2. Set JAVA_HOME in the /etc/profile file
  3. Confirmed that port 9998 and 9999 are not currently used
  4. Confirmed ports are no blocked by any firewall
  5. Review the splunk_app_db_connect_dbx.log, only info in the file is "update java path file [/opt/splunk/etc/apps/splunk_app_db_connect/linux_x86_64/bin/customized.java.path]"
  6. Confirmed the java path file has correct info
  7. Confirmed there are no unusual details in the inputs.conf
  8. Confirmed SElinux is not blocking

When running the command watch -n1 "ps -ef |grep java" , the java command is never executed.  However if I run the command watch -n1 "ps -ef|grep splunk"   when I attempt to save the setting in the app config I can Splunk attempting to run the command /opt/splunk/bin/python3.7 /opt/splunk/bin/runScript.py dbx_rh_proxy.ProxyManager

Labels (3)
0 Karma
1 Solution

ckeller2791
Explorer

It took a couple of reboots for it to resolve

View solution in original post

0 Karma

ckeller2791
Explorer

It took a couple of reboots for it to resolve

0 Karma
Get Updates on the Splunk Community!

Database Performance Sidebar Panel Now on APM Database Query Performance & Service ...

We’ve streamlined the troubleshooting experience for database-related service issues by adding a database ...

IM Landing Page Filter - Now Available

We’ve added the capability for you to filter across the summary details on the main Infrastructure Monitoring ...

Dynamic Links from Alerts to IM Navigators - New in Observability Cloud

Splunk continues to improve the troubleshooting experience in Observability Cloud with this latest enhancement ...