All Apps and Add-ons

Splunk App for Windows Infrastructure: All logs are coming to the indexer, but why is the dashboard not populating?

sathya2471
Engager

I have installed the Splunk App for Windows Infrastructure in my environment. All logs are coming to the indexer, but the dashboard is not populating. When I check for the search, it started with search: eventtype = "XXXXX". So, when I copy paste the same search in the search bar, it is not working when I add the prefix index = "*" it is working. Can any one help?

Thanks in advance

0 Karma
1 Solution

sathya2471
Engager

Hi,

I found the answer.

The key for me was "index=*" - that clued me in. It was just the indexes that were being searched by default.
Settings > Access Controls > Roles > Admin > Indexes searched by default (I added msad, permon and winevents)

Once i made the changes, i started seeing my data in my dashboards.

View solution in original post

sathya2471
Engager

Hi,

I found the answer.

The key for me was "index=*" - that clued me in. It was just the indexes that were being searched by default.
Settings > Access Controls > Roles > Admin > Indexes searched by default (I added msad, permon and winevents)

Once i made the changes, i started seeing my data in my dashboards.

Get Updates on the Splunk Community!

.conf24 | Day 0

Hello Splunk Community! My name is Chris, and I'm based in Canberra, Australia's capital, and I travelled for ...

Enhance Security Visibility with Splunk Enterprise Security 7.1 through Threat ...

 (view in My Videos)Struggling with alert fatigue, lack of context, and prioritization around security ...

Troubleshooting the OpenTelemetry Collector

  In this tech talk, you’ll learn how to troubleshoot the OpenTelemetry collector - from checking the ...