All Apps and Add-ons

Splunk App for NetApp Data ONTAP: After upgrade from 6.3.x to 6.4.0, why am I unable to connect to NetApp 7mode filer with error "_SSL: UNSUPPORTED_PROTOCOL"?

Engager

I am trying to connect to a 7mode Netapp filer, but I am having issues. The error I found using the search index=_internal (source=*ontap* OR source=*hydra*) ERROR gives the log line:

2016-05-20 11:19:57,444 ERROR _TAOntapConfService] __validate_ontap_server] Could not interact with ontap on host=somehost.com,       error: _OntapClient] Client Side Code Error 13001: _SSL: UNSUPPORTED_PROTOCOL] unsupported protocol (_ssl.c:603)

I'm at a loss trying to understand where the error is given this message. This error and issue only started coming up recently when we moved our test server from 6.3.* to 6.4. Prior to the upgrade, this connection was working. What can I do to resolve this error?

0 Karma
1 Solution

SplunkTrust
SplunkTrust

looks like the ontap_server url is not supporting HTTPS.

Please check your ontap configuration file and insure that your ontap_server address is correct. Maybe try opening the URL in your browser to see if the ontap is indeed supporting HTTPS or not.

View solution in original post

SplunkTrust
SplunkTrust

looks like the ontap_server url is not supporting HTTPS.

Please check your ontap configuration file and insure that your ontap_server address is correct. Maybe try opening the URL in your browser to see if the ontap is indeed supporting HTTPS or not.

View solution in original post

Engager

Thanks! This comment led us to eventually trying to configure a couple things differently on the ontap side. It looks like Splunk requires that the connection be TLS. If it isn't then this log error gets produced. So our fix was to make sure TLS was enabled on the ontap side.

If you'd like, please take this comment + yours and make it an answer. I can then mark this answered.

Explorer

We had the same issue upgrading from 6.2 to 6.4; a bunch of our filers dropped out of data collection.

To put a little extra detail on it, for 7-mode at least, this means setting

options httpd.admin.ssl.enable on
options tls.enable on

SplunkTrust
SplunkTrust

done. Thanks for coming back and reporting the results, etc!

0 Karma