All Apps and Add-ons
Highlighted

Splunk Add-On for Tenable: Why are these errors showing up after the update to version 5.1.2?

Explorer

Have had it working before, but Add-On for Tenable to use for Security Center is failing after update to 5.1.2 version. Using this version of the app on a Heavy Forwarder.

Using Security Center 5.6.1.

Using Splunk 7.0

Receiving the following two internal error logs from the app:

"17:54:35,059 +0000 log_level=ERROR, pid=7192, tid=MainThread, file=config.py, func_name=log, code_line_no=50 | UCC Config Module: Fail to load endpoint "global_settings" - Unspecified internal server error. reason={"messages":[{"type":"ERROR","text":"External handler failed with code '1' and output: 'REST ERROR[1021]: Fail to decrypt the encrypted credential information - cannot concatenate 'str' and 'NoneType' objects'.  See splunkd.log for stderr output."}]}"

And

"17:54:32,882 +0000 log_level=ERROR, pid=8140, tid=MainThread, file=config.py, func_name=log, code_line_no=50 | UCC Config Module: Fail to load endpoint "servers" - Unspecified internal server error. reason={"messages":[{"type":"ERROR","text":"External handler failed with code '1' and output: 'REST ERROR[1021]: Fail to decrypt the encrypted credential information - 'clear_password''.  See splunkd.log for stderr output."}]}"

We haven't seen these errors before when attempting to ingest logs. Connection should be good, .conf files look correct. Are there some .py files that need adjustment or any ideas? Thanks!

Re: Splunk Add-On for Tenable: Why are these errors showing up after the update to version 5.1.2?

Explorer

We are seeing an issue with the same log messages in an environment I support. Were you able to diagnose the issue?

0 Karma