All Apps and Add-ons
Highlighted

Setup for *nix app 5.0.2 not found.

New Member

I search the knowledge base first but what I found did not fix my issue -

I searched for that directory it is stating was linked to but it does not exist. I never had this issue in 5.x.

I tried upgrading the app for nix but would not work so since this was my test box (osx Mavericks) I decided to redo everything including Splunk base and all apps. The problem is *nix app won't get to the point where I can actually use it. Like I stated everything was removed and reinstalled. Splunk 6.0.3 and nix 5.0.2. Here is the error after I select what I want it to do and try and go to the dashboard and select setup ==>

Splunk for Unix Add-on: Setup

The I get:

404 Not Found

Return to Splunk home page

The path '/en-US/custom/search/taunixsetup/search/setup' was not found.

This page was linked to from macsrv.local:8000/en-US/app/search/setup.
0 Karma
Highlighted

Re: Setup for *nix app 5.0.2 not found.

Contributor

Hi,

I ran into this as well. For some reason, the way I had uploaded the app through the GUI and/or wiped & re-installed it via the command line didn't work.

To get this fixed (and to be able to find the setup page), I had to do the following.

1) stop splunk
2) remove the existing Splunk for *nix app, TA and addon
3) untar the splunk for *nix app into the etc/apps dir (either in $SPLUNK or in the SHP space)
4) restart splunk
5) kick off the splunk for *nix app, which brought me to the setup screen
6) kick off the splunk_ta app, which brought me to the setup screen

And I now have a working splunk for *nix app.

Highlighted

Re: Setup for *nix app 5.0.2 not found.

Splunk Employee
Splunk Employee

Nice tip! Sorry it doesn't quite work correctly for you guys through the UI-based app install.

0 Karma
Highlighted

Re: Setup for *nix app 5.0.2 not found.

New Member

This does not work. I've tried removing *nix app and TA and addon, loading from file, and untar method. I still get the 404 not found.

0 Karma