All Apps and Add-ons

S.o.S. supported on Splunk 6 but no Sideview Utils for Splunk 6?

mfrost8
Builder

I'm a little confused. While it looks like S.o.S. is compatible with Splunk 6 or so says the app page, it requires SideView Utils. However, the Sideview Utils I'm finding on Splunkbase is only compatible with Splunk 5.x.

Short of starting on Splunk 5 and then upgrading, how could one possibly make S.o.S. work on Splunk 6 without a Splunk-6 compatible version of Sideview Utils?

Thanks

1 Solution

sideview
SplunkTrust
SplunkTrust

Long story short, I have now updated Sideview Utils 1.3.5 as 6.0 compatible, which it in fact has always been. If anyone finds any problems let me know. (I had previously concluded there was no way to mark it compatible without actually upping the version number and I was trying to work it out. but it was just me not seeing the little links on the edit page)

However! You should use the latest version of Sideview Utils which is 2.6.5. It is free for internal use, it has hundreds of bugfixes, performance improvements. It has more features, it has better docs, better examples... It is a much better and more mature product.

http://apps.splunk.com/app/1486/

Thousands of companies have already upgraded to the 2.X versions, so switch today.

Licensing:

If you are using it only in your company's internal Splunk deployment(s), the "internal use" restriction is no restriction at all. Meaning that Sideview Utils 2.6.5 is just as free as 1.3.5 was.

And if you want to develop an app or a solution on top of Splunk, and you want to use Sideview Utils modules (build a better app in less time, and tear out less hair maintaining it), then Contact Sideview about an OEM license. The cost is only $5K USD per year per app. With faster iterations and easier maintenance it'll pay for itself in weeks.

View solution in original post

sideview
SplunkTrust
SplunkTrust

Long story short, I have now updated Sideview Utils 1.3.5 as 6.0 compatible, which it in fact has always been. If anyone finds any problems let me know. (I had previously concluded there was no way to mark it compatible without actually upping the version number and I was trying to work it out. but it was just me not seeing the little links on the edit page)

However! You should use the latest version of Sideview Utils which is 2.6.5. It is free for internal use, it has hundreds of bugfixes, performance improvements. It has more features, it has better docs, better examples... It is a much better and more mature product.

http://apps.splunk.com/app/1486/

Thousands of companies have already upgraded to the 2.X versions, so switch today.

Licensing:

If you are using it only in your company's internal Splunk deployment(s), the "internal use" restriction is no restriction at all. Meaning that Sideview Utils 2.6.5 is just as free as 1.3.5 was.

And if you want to develop an app or a solution on top of Splunk, and you want to use Sideview Utils modules (build a better app in less time, and tear out less hair maintaining it), then Contact Sideview about an OEM license. The cost is only $5K USD per year per app. With faster iterations and easier maintenance it'll pay for itself in weeks.

View solution in original post

matt
Splunk Employee
Splunk Employee

Our testing shows that the new S.o.S is fully functioning in Splunk 6. Sideview will update their compatability table after they have had time to run through their full test suite on Splunk 6.

ChrisG
Splunk Employee
Splunk Employee

...and Sideview has said in the #splunk IRC channel: "If anyone asks or is curious, Sideview Utils works on 6.0."

miwalker
Explorer

I just installed the old sideview via http://apps.splunk.com/app/466/ by downloading the tarball and installing in the Splunk 6 UI in my test environment. No compatibility issues.