All Apps and Add-ons

Not able to open new app in splunk app framework

gajananh999
Contributor

Hello Everyone,

I have installed Splunk app framework with following these instruction

https://github.com/splunk/splunk-demo-musicdashboard

i have created one app and tried to open its giving the error like

Page not found (404)
Request Method: GET
Request URL: http://ec2-xx-xx-35-241.compute-1.amazonaws.com:3000/appfx/musicdashboard/
Using the URLconf defined in urls, Django tried these URL patterns, in this order:
^$ [name='home']
^accounts/login/$ [name='login']
^accounts/logout/$ [name='logout']
^sxml/(?P\w+)/(?P.+)$ [name='render_simplexml']
^homefx/
^testfx/
^componentfx/
^quickstartfx/
^examplesfx/
The current URL, musicdashboard/, didn't match any of these.
You're seeing this error because you have DEBUG = True in your Django settings file. Change that to False, and Django will display a standard 404 page.

Can anyone plsease help me on this.

Thanks

Gajanan Hiroji

Tags (2)

helge
Builder

Did you restart Splunkweb after creating the app? I had the same issue when I only restarted Splunkd, not Splunkweb.

thesteve
Path Finder

Thank you for that! I had the same issue with 6.1 only I was receiving "Invalid Language Specified" Restarting the splunk web service resolved the problem.

0 Karma

gajananh999
Contributor

Can anyone please help me on this.

0 Karma
Get Updates on the Splunk Community!

Routing Data to Different Splunk Indexes in the OpenTelemetry Collector

This blog post is part of an ongoing series on OpenTelemetry. The OpenTelemetry project is the second largest ...

Getting Started with AIOps: Event Correlation Basics and Alert Storm Detection in ...

Getting Started with AIOps:Event Correlation Basics and Alert Storm Detection in Splunk IT Service ...

Register to Attend BSides SPL 2022 - It's all Happening October 18!

Join like-minded individuals for technical sessions on everything Splunk!  This is a community-led and run ...