All Apps and Add-ons

MQTT Modular Input: Does not start, receives error

pau3bk
Engager

MQTT Modular Input does not start.

Error Message is:

   Introspecting scheme=mqtt: script running failed (exited with code 1)
   Unable to initialize modular input "mqtt" defined inside the app "mqtt_ta": Introspecting scheme=mqtt: script running failed (exited with code 1)

I changed mqtt.py to log the Java call (see below).

When I start it from a command line, the error appears (not belonging to Java): ERROR Incorrect Program Usage
Nothing else. Any idea?

C:\Tools\jdk-12.0.1\bin\java -classpath C:\Tools\Splunk\etc\apps\mqtt_ta\bin\lib\commons-codec-1.9.jar;C:\Tools\Splunk\etc\apps\mqtt_ta\bin\lib\commons-logging-1.2.jar;C:\Tools\Splunk\etc\apps\mqtt_ta\bin\lib\httpasyncclient-4.1.jar;C:\Tools\Splunk\etc\apps\mqtt_ta\bin\lib\httpasyncclient-cache-4.1.jar;C:\Tools\Splunk\etc\apps\mqtt_ta\bin\lib\httpclient-4.4.1.jar;C:\Tools\Splunk\etc\apps\mqtt_ta\bin\lib\httpclient-cache-4.4.1.jar;C:\Tools\Splunk\etc\apps\mqtt_ta\bin\lib\httpcore-4.4.1.jar;C:\Tools\Splunk\etc\apps\mqtt_ta\bin\lib\httpcore-nio-4.4.1.jar;C:\Tools\Splunk\etc\apps\mqtt_ta\bin\lib\json.jar;C:\Tools\Splunk\etc\apps\mqtt_ta\bin\lib\log4j-1.2.16.jar;C:\Tools\Splunk\etc\apps\mqtt_ta\bin\lib\mqtt-client-0.4.0.jar;C:\Tools\Splunk\etc\apps\mqtt_ta\bin\lib\mqttmodinput.jar;C:\Tools\Splunk\etc\apps\mqtt_ta\bin\lib\splunk_tlsv12.jar; -Xms64m  -Xmx64m  -Dsplunk.securetransport.protocol=tls com.splunk.modinput.mqtt.MQTTModularInput

cbreezier
Engager

This is very late, but I ran into the same error.

I saw a hint at https://community.splunk.com/t5/All-Apps-and-Add-ons/Unable-to-initialize-modular-input-quot-mqtt-qu...

I also found a page about troubleshooting add-ons: https://docs.splunk.com/Documentation/AddOns/released/Overview/Troubleshootadd-ons

Which allowed me to find the following log from the add-on for more information:

07-20-2020 06:43:40.050 +0000 ERROR ModularInputs - <stderr> Introspecting scheme=mqtt: java: symbol lookup error: java: undefined symbol: JLI_StringDup

And then I found this bug: https://bugs.launchpad.net/ubuntu/+source/openjdk-lts/+bug/1882208

So I downgraded to openjdk-8 and all is well for me (I was on openjdk-11). I see that you're running jdk-12, which is likely to be your problem.

0 Karma
Get Updates on the Splunk Community!

.conf24 | Day 0

Hello Splunk Community! My name is Chris, and I'm based in Canberra, Australia's capital, and I travelled for ...

Enhance Security Visibility with Splunk Enterprise Security 7.1 through Threat ...

 (view in My Videos)Struggling with alert fatigue, lack of context, and prioritization around security ...

Troubleshooting the OpenTelemetry Collector

  In this tech talk, you’ll learn how to troubleshoot the OpenTelemetry collector - from checking the ...