All Apps and Add-ons

Lookup editor - application labels with parentheses fail to show lookup files

SplunkTrust
SplunkTrust

In lookup file editor 3.3.1, I found that if the application label includes certain special characters, in this case parentheses, the app dropdown results in "No matching records found"

For example if my application label is "Test (test)", then on the global screen of the lookup editor I can see the lookups within the application.
However if I choose the app from the dropdown menu, then No matching records found appears.

I suspect this relates to the javascript the app is using to filter the results, is it possible to have this fixed?

Thanks

0 Karma
1 Solution

Champion

I opened a bug opened to get this fixed in the next maintenance release: https://lukemurphey.net/issues/2433

View solution in original post

0 Karma

Champion

I opened a bug opened to get this fixed in the next maintenance release: https://lukemurphey.net/issues/2433

View solution in original post

0 Karma

SplunkTrust
SplunkTrust

To be clear, if I rename the label of the app (not the app itself) to test_test the filtering in the lookup editor app works just fine

The app directory on disk never had the parentheses in it...(only the label)

0 Karma

Super Champion

Hi @gjanders,

Are the names fixed and unchangeable ? Would it be easier for you to define a strict naming convention for knowledge objects to avoid having special characters in them ? That would save you a lot of time and trouble. It will also allow you to sort more easily on the objects and group them as needed.

Something like sales_accounts.csv, sales_products.csv would be easier to maintain compared to test (test) sales

0 Karma

SplunkTrust
SplunkTrust

@DavidHourani perhaps my wording was not clear enough. It is the application label that matters, not the CSV file name. We would not let someone use special characters in the CSV / lookup name itself.

As a workaround we have changed the label of the applications in question, but when the application label is Test ( test ), then the lookup editor shows 0 lookups when filtering to it...

But the lookups remain visible if you do not narrow down to the app within the lookup editor.

Changing the application label resolves the issue.

0 Karma

Super Champion

ouch... nice catch, I hope one of the lookup file editor sees this post to fix that for next version..

0 Karma
Don’t Miss Global Splunk
User Groups Week!

Free LIVE events worldwide 2/8-2/12
Connect, learn, and collect rad prizes
and swag!