All Apps and Add-ons

JSChart using Sideview in 4.3.1?

Contributor

FlashChart works but JSChart does not seem to work?


<![CDATA[My nice JSChart Pie Chart]]>

search mysearch

pie




1 Solution

SplunkTrust
SplunkTrust

I think what you're hitting is more likely to be a bug in the Splunk JSChart module. I know of at least one bug in the JSChart where it wont work in situations where FlashChart and SimpleResultsTable work just fine. That specific bug is that in some situations when JSChart is given a search job that is already dispatched and done, it never renders.

Therefore, at a guess, is the job you're trying to render results from perhaps from Splunk's HiddenSavedSearch module, or from Sideview's SavedSearch module?

In any event, please do send all the XML to me at nick at sideviewapps.com, or post it here. I'll investigate what's going on and let you know what I find.

UPDATE:

Thanks for confirming that there's a HiddenSavedSearch up there. Indeed, that's exactly what was causing it -- the bug I mentioned in JSChart that I helped Splunk diagnose recently. I can't say for sure obviously but I suspect the fix will be out in the next maintenance release of 4.3.

In the meantime, you'll have to either use an ad-hoc search there instead of the scheduled search, or use a real-time search, or use FlashChart or SimpleResultsTable for the time being instead of JSChart...

I can also look into patching the bug from the Sideview Development Kit, which wouldn't be very hard.

View solution in original post

SplunkTrust
SplunkTrust

I think what you're hitting is more likely to be a bug in the Splunk JSChart module. I know of at least one bug in the JSChart where it wont work in situations where FlashChart and SimpleResultsTable work just fine. That specific bug is that in some situations when JSChart is given a search job that is already dispatched and done, it never renders.

Therefore, at a guess, is the job you're trying to render results from perhaps from Splunk's HiddenSavedSearch module, or from Sideview's SavedSearch module?

In any event, please do send all the XML to me at nick at sideviewapps.com, or post it here. I'll investigate what's going on and let you know what I find.

UPDATE:

Thanks for confirming that there's a HiddenSavedSearch up there. Indeed, that's exactly what was causing it -- the bug I mentioned in JSChart that I helped Splunk diagnose recently. I can't say for sure obviously but I suspect the fix will be out in the next maintenance release of 4.3.

In the meantime, you'll have to either use an ad-hoc search there instead of the scheduled search, or use a real-time search, or use FlashChart or SimpleResultsTable for the time being instead of JSChart...

I can also look into patching the bug from the Sideview Development Kit, which wouldn't be very hard.

View solution in original post

Contributor

Excellent - thanks Ellen!

0 Karma

Splunk Employee
Splunk Employee

This is a known issue, SPL-50300 reported in 4.3.2 and anticipating a fix in the next maintenance release.

0 Karma

SplunkTrust
SplunkTrust

Gotcha. Yep that's the bug then. You're hitting the bug in JSChart that I mentioned. I updated my answer above.

0 Karma

Contributor

Yes, I have a hiddensavedsearch upstream

<![CDATA[Some Heading Here]]>

search_summary

If I replace the code in the initial post with FlashChart, the pie chart renders fine. In JSChart it looks like there might be something behind the scenes going on, but the panel is all blank white - i.e. it isnt rendering.

0 Karma