All Apps and Add-ons

Is there a way to force the Splunk Add-on for Java Management Extensions to use tls?

Path Finder

Hello there,

if I set on server.conf the option "sslVersions = tls" the App stops working with the message:

03-19-2015 16:00:16.294 +0100 WARN  HttpListener - Socket error from 127.0.0.1 while idling: error:1408A10B:SSL routines:SSL3_GET_CLIENT_HELLO:wrong version number
03-19-2015 16:00:16.297 +0100 ERROR ExecProcessor - message from "python /opt/splunkforwarder/etc/apps/Splunk_TA_jmx/bin/jmx.py" Error executing modular input : Received fatal alert: handshake_failure : java.lang.RuntimeException: Received fatal alert: handshake_failure

Is there a way to force Splunk_TA_jmx to use tls?

0 Karma
1 Solution

Path Finder

Just a follow up.
Since I'm running this App on Version 3.0.1 and Java 1.8 the Protocol problem ist solved.

View solution in original post

0 Karma

Path Finder

Just a follow up.
Since I'm running this App on Version 3.0.1 and Java 1.8 the Protocol problem ist solved.

View solution in original post

0 Karma

Splunk Employee
Splunk Employee

Hi, here's a guess from an offline conversation:

https://blogs.oracle.com/java-platform-group/entry/diagnosing_tls_ssl_and_https
Controls the protocol version used by Java clients. For older versions, this can update the default in case your Java 7 client wants to use TLS 1.2 as its default.
Example: -Dhttps.protocols=TLSv1,TLSv1.1,TLSv1.2
so the guess is to change/add/whatever the properties to the JVM used by the JMX AddOn.

Path Finder

Hello and thank you for your answer,

I managed to put it to work with your suggestion, but unfortunately only after I changed the python script to get this java parameter hardcoded. So it will probably be lost during the next add on update.
I'll have to mark it as a workaround until Splunk finds a way to make it parametrizable.