All Apps and Add-ons

How to fix "Invalid key in stanza" issue?

rendie
Path Finder

Hi all, I have little issue with input made via Add-on Builder (Python3). I have been made some inputs and all other inputs work correctly, but only one does not run, and in _internal a have error "Invalid key in stanza [input_http] in /opt/splunk/etc/apps/application-for-splunk/default/inputs.conf, line 68: python.version (value: python3)." I use Add-on builder version 3.0.1 and Splunk Enterprise 7.3.1.1.

How I can fix it?

Thanks.

ricotries
Communicator

Splunk is complaining that there is a key under a header that it does not recognize. Briefly looking at inputs.conf reference manual for 7.3.1 (here) you can see that neither [input_http] nor python.version are recognized by that version of Splunk. The reason your input is not working is most likely due to being placed under a header that Splunk does not know what it means for inputs.conf (the python.version invalid key is most likely not the source of the issue, it would most likely be ignored).

Splunk uses the Python 3 interpreter by default so there's no need to specify it (as well as the fact that in inputs.conf, there is no key for "python.version").

If you are trying to enable a HTTP Event Collector Input, use the settings shown under this category.

Get Updates on the Splunk Community!

Welcome to the Splunk Community!

(view in My Videos) We're so glad you're here! The Splunk Community is place to connect, learn, give back, and ...

Tech Talk | Elevating Digital Service Excellence: The Synergy of Splunk RUM & APM

Elevating Digital Service Excellence: The Synergy of Real User Monitoring and Application Performance ...

Adoption of RUM and APM at Splunk

    Unleash the power of Splunk Observability   Watch Now In this can't miss Tech Talk! The Splunk Growth ...