All Apps and Add-ons

How to enable kvstore in Splunk 6.2.2 to finish setting up the Splunk App for Windows Infrastructure?

arber
Communicator

Hi,

we have splunk 6.2.2 installed and we are trying to get windows inf app running. However, the only step not completed is the enable of kvstore.

Is there a way to enable that and make the app running ?

Thanks

Arber

0 Karma
1 Solution

malmoore
Splunk Employee
Splunk Employee

By default kvstore should be enabled on Splunk Enterprise 6.2.

If it isn't, it's likely because of a file permission or lock issue that's causing the service to fail to start silently.

Take a look at $SPLUNK_HOME/var/log/splunk/mongod.log for clues as to why the service hasn't started.

View solution in original post

malmoore
Splunk Employee
Splunk Employee

By default kvstore should be enabled on Splunk Enterprise 6.2.

If it isn't, it's likely because of a file permission or lock issue that's causing the service to fail to start silently.

Take a look at $SPLUNK_HOME/var/log/splunk/mongod.log for clues as to why the service hasn't started.

View solution in original post

ChrisG
Splunk Employee
Splunk Employee

...and try restarting the mongod service manually.

0 Karma

arber
Communicator

Thanks for the answer, Actually checking mongod.log file we found out that the key used with the certificate bound to port 8089 could not be read . Therfore the service was not started. So we removed that key and now it is ok.
The problem is that in our environment we need to change the default certs of splunk and use ours. So we have to check how can we use our certs in order not to cause issue to the system

Thanks

0 Karma
.conf21 Now Fully Virtual!
Register for FREE Today!

We've made .conf21 totally virtual and totally FREE! Our completely online experience will run from 10/19 through 10/20 with some additional events, too!