All Apps and Add-ons

How to disable drilldown in a Timeline Chart?

robertlynch2020
Influencer

Hi

I have the following Timeline chart and i am looking to disable the drill down, however it doe snot seem possible..

I have tried to use the normal disable commands but they don't work. Any ideas would be great 🙂

 <panel depends="$TPS_ON_OFF$,$TPS_ON_ALL_PANELLS$,$GANTT_CHART_ON$">
      <title>TPS Real-Time Activity Gantt Chart: = $TPS_Class_token$</title>
      <viz type="timeline_app.timeline">
        <search>
          <query>| tstats summariesonly=$summariesonly_token$ max(All_TPS_Logs.duration) AS All_TPS_Logs.duration FROM datamodel=MLC_TPS_DEBUG4 WHERE (nodename=All_TPS_Logs host=$host_token$) All_TPS_Logs.name =*$TPS_Class_token$* GROUPBY _time, All_TPS_Logs.$fullyQualifiedMethod_or_class$ span=1s | rename All_TPS_Logs.$fullyQualifiedMethod_or_class$ as opId | table _time opId All_TPS_Logs.duration</query>
          <earliest>$tps_selection.earliest$</earliest>
          <latest>$tps_selection.latest$</latest>
        </search>
        <option name="height">400</option>
        <option name="timeline_app.timeline.axisTimeFormat">SUBSECONDS</option>
        <option name="timeline_app.timeline.colorMode">categorical</option>
        <option name="timeline_app.timeline.maxColor">#DA5C5C</option>
        <option name="timeline_app.timeline.minColor">#FFE8E8</option>
        <option name="timeline_app.timeline.numOfBins">6</option>
        <option name="timeline_app.timeline.tooltipTimeFormat">SUBSECONDS</option>
        <option name="timeline_app.timeline.useColors">false</option>
        <option name="charting.drilldown">false</option>
      </viz>
    </panel>
1 Solution

niketn
Legend

Try the following code which performs a dummy drilldown to set a token, hence disables actual drilldown.

    <drilldown>
      <set token="dummy">true</set>
    </drilldown>
____________________________________________
| makeresults | eval message= "Happy Splunking!!!"

View solution in original post

0 Karma

jeffland
SplunkTrust
SplunkTrust

You were almost there, setting <option name="charting.drilldown">none</option> instead of false would have been the way. Docs here.

niketn
Legend

@jeffland, this question was for Timeline Custom Visualization a property like charting.drilldown is not applicable. Also I think @robertlynch2020 had already tried timeline_app.timeline.drilldown, which is not exposed. Which I why I suggested a workaround in Simple XML.

____________________________________________
| makeresults | eval message= "Happy Splunking!!!"
0 Karma

jeffland
SplunkTrust
SplunkTrust

Ah - sorry, didn't see the tag and misread "timeline chart" as "a splunk chart based on a timeline".

0 Karma

niketn
Legend

Try the following code which performs a dummy drilldown to set a token, hence disables actual drilldown.

    <drilldown>
      <set token="dummy">true</set>
    </drilldown>
____________________________________________
| makeresults | eval message= "Happy Splunking!!!"
0 Karma

robertlynch2020
Influencer

cheers 🙂

0 Karma
Get Updates on the Splunk Community!

Optimize Cloud Monitoring

  TECH TALKS Optimize Cloud Monitoring Tuesday, August 13, 2024  |  11:00AM–12:00PM PST   Register to ...

What's New in Splunk Cloud Platform 9.2.2403?

Hi Splunky people! We are excited to share the newest updates in Splunk Cloud Platform 9.2.2403! Analysts can ...

Stay Connected: Your Guide to July and August Tech Talks, Office Hours, and Webinars!

Dive into our sizzling summer lineup for July and August Community Office Hours and Tech Talks. Scroll down to ...