All Apps and Add-ons

ERROR DeployedApplication - Failed to install app=/web/splunk/etc/master-apps/s; reason=Application does not exist

nls7010
Path Finder

I am receiving the above error when trying to deploy update and new apps from the Cluster Master to the Indexer Cluster. The aspps do exist in /web/splunk/etc/managed-apps directory structure on the cluster master, but I still get this error. I have reviewed several Answers and none of them have worked for us. Recently we worked on the indexes.conf to standardize some features, I'm wondering if that may have caused it. All we did was remove The repFactor-auto from each index (there are about 35) and put it in the [default] and also removed the maxTotalDataSizeMB from each of the index configuration and put it in the default stanza.

Now when we push a bundle, we get the Failed to install app with the application does not exist. Would really appreciate any assistance you can give me.

0 Karma

codebuilder
Influencer

When you see this error it generally means that the Splunk user does not have read privileges on the master-apps directory or it's sub-directories. This can happen if/when you're making manual changes as root, or you scp/rsync files over, etc.

Check the user:group ownerships on those directories and the read/write permissions.
If necessary, perform a recursive chown (e.g.):

chown -RP splunk:splunk master-apps/
----
An upvote would be appreciated and Accept Solution if it helps!

dka_duncan
New Member

I have looked at permissions, and it's not that.

My situation is slightly different as I am using the DS to send apps to two different locations. ../etc/master-apps for building cluster bundles as well as .../etc/apps/ for monitoring the Manager Node (aka CM) 
So in the serverclass.conf I have


[serverClass:<some serverclass name>]
machineTypesFilter = linux-x86_64
restartSplunkd = false
stateOnClient = noop
targetRepositoryLocation = /apps/splunk/etc/master-apps
whitelist.0 = <manager_node>

[serverClass:<some serverclass name>:app:<some app name>]
restartSplunkWeb = 0
restartSplunkd = 0
stateOnClient = enabled

Well this end up as failed to install app
ERROR DeployedServerclass - name=<some serverclass name> Failed to install app=<some app name>
ERROR DeployedApplication - Failed to install app=/apps/splunk/etc/shcluster/apps/<some app name>; reason=Application does not exist: <some app name>

Now when I do this:

[serverClass:<some serverclass name>:app:<some app name>]
restartSplunkWeb = 0
restartSplunkd = 0
#stateOnClient = enabled 

We get this:

INFO DeployedApplication - Installing app=<some app name> to='/apps/splunk/etc/shcluster/apps/<some app name>'
INFO DeployedApplication - Downloaded url=<host DS server>:8089/services/streams/deployment?name=default:<some serverclass name>:<some app name> to file='/apps/splunk/var/run/<some serverclass name>/<some app name>-1633360622.bundle' sizeKB=10

 

And this has nothing to do with permissions - something 'buggy(?)' I have a case raised. This is my work around not elegant but seems to do the trick.

Regards Duncan
PS The version is 8.1.6 

 

Tags (1)
0 Karma
Get Updates on the Splunk Community!

2024 Splunk Career Impact Survey | Earn a $20 gift card for participating!

Hear ye, hear ye! The time has come again for Splunk's annual Career Impact Survey!  We need your help by ...

Optimize Cloud Monitoring

  TECH TALKS Optimize Cloud Monitoring Tuesday, August 13, 2024  |  11:00AM–12:00PM PST   Register to ...

What's New in Splunk Cloud Platform 9.2.2403?

Hi Splunky people! We are excited to share the newest updates in Splunk Cloud Platform 9.2.2403! Analysts can ...