All Apps and Add-ons

Does anyone have any guidance for my DB Connect 3.1.3 Java installation Issue?


Simple development/test setup single splunk server with DB Connect 3.1.3 installed. Installed Java 1.8_181 to the following directory:


Set java home variables, etc. I get no error messages when I select the DB Connect app, I just get a spinning wheel. Checked the log files within the Splunk directory, anyone have any guidance? Thanks.

0 Karma


Yeah the monitor has to review, hopefully it will pop up in a second. I used both jre and jdk 1.8 181 using yum local install which puts it into /usr/java/, updated java_home variable and put the path in the dbx_settings.conf file. Did not work. Followed the steps you provided only difference was I was using the 1.8 181 vs 172 version, same result.

Guess I can see if I can find the 172 version to try and see what happens, but would not think that would be an issue.

This is on CentOS as an FYI, full patched, nothing else on the system but Splunk and Splunk Stream.

0 Karma

Splunk Employee
Splunk Employee

hi @jeburkes76

Did either of the answers below solve your problem? If so, please resolve this question by approving one of them. If your problem is still not solved, keep us updated so that someone else can help ya.

0 Karma

Esteemed Legend

There is good logging described in the troubleshooting section:

I always have good success carefully following the docs:

0 Karma


I followed the checklist. I also tried the troubleshooting, but not getting any hits. Seems to be a java issue, as I am not seeing errors in any splunk logs. Additionally, see my response above to PaoloR84, thanks.

0 Karma

New Member

I can't see your answer to me but, with the steps I sent you. it must work (yesterday I was installing a DBConnect and I sent you my cli commands 🙂 !)

Have you used the same jre version?

0 Karma

New Member

You have to use the server version, ie: server-jre-8u172-linux-x64.tar.gz

Assuming you will install it in /opt, ie:
tar zxvf server-jre-8u172-linux-x64.tar.gz -C /opt/

the java path in DBConnect will be /opt/jdk1.8.0_172/jre/

After that, in case your rpc server hasn't started, restart splunk and everything should be ok!

0 Karma


To provide more information I have installed both the JRE and JDK 1.8.0_181. Both get installed to /usr/java/, since they are "separate" versions they are in separate folders. For each version I put the $JAVA_HOME and $JRE_HOME to their respective paths, rebooted the splunk server, and still end up with a spinning wheel. I also set the dbx_settings.conf file java path variable. Here is what I tested:

Using JRE:
$JAVA_HOME: /usr/java/jre1.8.0_181-amd64/
$JRE_HOME: /usr/java/jre1.8.0_181-amd64/
dbxsettings.conf under [java] javahome = /usr/java/jre1.8.0_181-amd64/

Using JDK:
$JAVA_HOME: /usr/java/jdk1.8.0_181-amd64/
$JRE_HOME: /usr/java/jdk1.8.0_181-amd64/jre
dbxsettings.conf under [java] javahome = /usr/java/jdk1.8.0_181-amd64/jre/

Your Steps:

I used the server-jre-8u181-linux.tar.gz, put it in /opt/ and updated the dbx_settings.conf file,updated $JAVA_HOME and $JRE_HOME variables rebooted.

All three configurations above leave me with a spinning wheel when I go to configure DB Connect. I did more research in the Splunk Community and found these posts that related to my issue, but they do not have resolutions:

Any ideas? Thanks for the help.

0 Karma

New Member

Is there a specific reason for not using the DBConnect GUI?
Via GUI, under "Configuration" > "Settings" tab "General" you should have:

JRE Installation Path(JAVA_HOME)

JVM Options

Task Server Port

Click "Save"

It's quite difficult, but check if the port 9998 is already opened by another process.

0 Karma


GUI page doesn't come up, when I click on Apps and select DB Connect, it takes me to the DB Connect page and I see the configuration tabs, etc. for a quick second then it automatically redirects to a welcome page. If you look at the other issues I linked you will see there is a ftr.js error:

Uncaught (in promise) TypeError: Cannot read property 'Symbol(Symbol.iterator)' of undefined
at ftr.js:1

Tried two different Windows systems and used Chrome and IE on each just to make sure it wasn't a client side issue. Get the above error, so I thought it was possible a java issue on the server. Verified javascript was allowed on all browsers.

I did verify that DB Connect is using 9998 and ensured the firewall allowed connectivity. I can stop splunk and watch port 9998 disappear by performing netstat and then start it back up and watching port 9998 being used by netstat. I did this a couple of days ago.

I also performed a ./splunk stop and ./splunk start to see if any errors popped up, nothing.

If I remove java, including the installations from /usr/java, environmental variables, and remove the dbx_settings.conf and just leave the jdk installed in /opt/ directory and reboot, I get this error:

Unable to initialize modular input "server" defined inside the app "splunk_app_db_connect": Introspecting scheme=server: script running failed (exited with code 127).

If I ignore the error and try to click on DB Connect I still get the spinning wheel and the ftr.js error, I first assumed based on other community posts that I needed to get java sorted out to get the configuration page to display. So if I configure java and reboot the error message above goes away but the spinning wheel and ftr.js error remains. Basically java configured or not ftr.js on the welcome page occurs.

Can you provide the path to the configuration page? https://:8000/en-US/app/splunk_app_db_connect/

I wonder if I can bypass the welcome page and get to the configuration page.

0 Karma