All Apps and Add-ons

Data Model Network_Traffic doesn't work

ahsaine
New Member

I am new on Splunk. I am using Infosec app and I have question please.
I am getting logs from the firewall after executing this command: | datamodel Network_Traffic All_Traffic search
But the Network_Traffic data model doesn't show any results after this request: | tstats summariesonly=true allow_old_summaries=true count from datamodel=Network_Traffic.All_Traffic where (All_Traffic.action=blocked OR All_Traffic.action=deny)
Any idea how to resolve this??

0 Karma

richgalloway
SplunkTrust
SplunkTrust

The tstats command doesn't like datasets in the datamodel option. Use the nodename option, instead.

... | tstats summariesonly=true allow_old_summaries=true count from datamodel=Network_Traffic where nodename=Network_Traffic.All_Traffic  (All_Traffic.action=blocked OR All_Traffic.action=deny)
---
If this reply helps you, Karma would be appreciated.
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Thanks for the Memories: .conf26 Took Learning to New Heights

Thank you, Splunk Community, for making .conf26 in Denver one for the books. From packed Splunk University ...

Best Practices: Splunk auto adjust pipeline queue

When you enable autoAdjustQueue in Splunk, maxSize should be understood as the queue size Splunk starts with ...

Splunk Auto Ingestion Parallel Pipeline Scaling

Why this feature matters Many Splunk environments experience ingestion pressure long before the host is fully ...