All Apps and Add-ons

DBX will not load after update to 3.1.3. Cannot communicate with task server, please check your settings. /opt/splunk/etc/apps/TA-Proofpoint-TAP...

jpondrom_splunk
Splunk Employee
Splunk Employee

When running Splunk 7.1.2 and splunk_app_db_connect 3.1.3 and TA-Proofpoint-TAP 1.3.117 it keeps DBX from loading. With the below error.

Cannot communicate with task server, please check your settings.

Traceback (most recent call last): File "/opt/splunk/bin/rest_handler.py", line 79, in print splunk.rest.dispatch(**params) File "/opt/splunk/lib/python2.7/site-packages/splunk/rest/init.py", line 149, in dispatch module = __import('splunk.rest.external.%s' % parts[0], None, None, parts[0]) File "/opt/splunk/etc/apps/splunk_app_db_connect/bin/dbxproxy.py", line 7, in from dbx_settings import Settings File "/opt/splunk/etc/apps/splunk_app_db_connect/bin/dbxsettings.py", line 10, in import splunklib.client as client File "/opt/splunk/etc/apps/TA-Proofpoint-TAP/bin/splunklib/_init.py", line 18, in from splunklib.six.moves import map ImportError: No module named six.moves

0 Karma

jpondrom_splunk
Splunk Employee
Splunk Employee

This is caused by a compatibility issue between TA-Proofpoint-TAP 1.3.117 and DBX 3.1.3.
To work around the error, and resolve the issue please downgrade the TA-Proofpoint-TAP to version 1.0.1

0 Karma

jypyking
Explorer

Hi there, just in case this can help. I had the exact same issue and wanted to stay on both versions mentioned above.
My workaround was to copy the splunklib folder from /opt/splunk/etc/apps/splunk_instrumentation/bin/splunk_instrumentation/splunklib to /opt/splunk/etc/apps/splunk_app_db_connect/bin/splunklib

Works perfectly now.

*NEW* Splunk Love Promo!
Snag a $25 Visa Gift Card for Giving Your Review!

It's another Splunk Love Special! For a limited time, you can review one of our select Splunk products through Gartner Peer Insights and receive a $25 Visa gift card!

Review:





Or Learn More in Our Blog >>