All Apps and Add-ons
Highlighted

DBConnect "cannot communicate with task server"

Motivator

Splunk 7.2 running on Ubuntu. I specified /usr/lib/jre1.8.0_191.... tried ports 9998 and 1025.

Cannot communicate with task server, please check your settings
Tags (1)
0 Karma
Highlighted

Re: DBConnect "cannot communicate with task server"

Motivator

Lmfao, here's the answer.

So in the newer 3+ versions of DBConnect (by new, I mean multiple years old and somehow someone thought it was unacceptable NOT to do anything about it), you need to specify the JDK path, not JRE. Forget the fact that every version of DBconnect ever has pointed to the JRE, and forget the fact that it literally says to enter the "JRE Installation Path." Here's a suggestion: maybe the configuration shouldn't ASK for the JRE path?? It literally says JRE Installation Path. Just edit one line of your code guys.

Second, that still didn't fix the problem. It gave me the same error message after trying it with the JDK. You need to magically know that, despite getting an error message, despite it telling you it was unable to save your settings or start the task server, everything is actually okay. If you reboot Splunk DBconnect will now be configured.

#logic

View solution in original post

0 Karma
Highlighted

Re: DBConnect "cannot communicate with task server"

Explorer

There might be the issue with httpinput app. check the folder- $SPLUNKHOME/etc/apps/htttpinput. Make sure this directory is available.

0 Karma
Speak Up for Splunk Careers!

We want to better understand the impact Splunk experience and expertise has has on individuals' careers, and help highlight the growing demand for Splunk skills.