All Apps and Add-ons

DBConnect "cannot communicate with task server"

nick405060
Motivator

Splunk 7.2 running on Ubuntu. I specified /usr/lib/jre1.8.0_191.... tried ports 9998 and 1025.

Cannot communicate with task server, please check your settings
Tags (1)
0 Karma
1 Solution

nick405060
Motivator

Lmfao, here's the answer.

So in the newer 3+ versions of DBConnect (by new, I mean multiple years old and somehow someone thought it was unacceptable NOT to do anything about it), you need to specify the JDK path, not JRE. Forget the fact that every version of DBconnect ever has pointed to the JRE, and forget the fact that it literally says to enter the "JRE Installation Path." Here's a suggestion: maybe the configuration shouldn't ASK for the JRE path?? It literally says JRE Installation Path. Just edit one line of your code guys.

Second, that still didn't fix the problem. It gave me the same error message after trying it with the JDK. You need to magically know that, despite getting an error message, despite it telling you it was unable to save your settings or start the task server, everything is actually okay. If you reboot Splunk DBconnect will now be configured.

#logic

View solution in original post

ManchitMalik
Explorer

There might be the issue with httpinput app. check the folder- $SPLUNK_HOME/etc/apps/htttp_input. Make sure this directory is available.

0 Karma

nick405060
Motivator

Lmfao, here's the answer.

So in the newer 3+ versions of DBConnect (by new, I mean multiple years old and somehow someone thought it was unacceptable NOT to do anything about it), you need to specify the JDK path, not JRE. Forget the fact that every version of DBconnect ever has pointed to the JRE, and forget the fact that it literally says to enter the "JRE Installation Path." Here's a suggestion: maybe the configuration shouldn't ASK for the JRE path?? It literally says JRE Installation Path. Just edit one line of your code guys.

Second, that still didn't fix the problem. It gave me the same error message after trying it with the JDK. You need to magically know that, despite getting an error message, despite it telling you it was unable to save your settings or start the task server, everything is actually okay. If you reboot Splunk DBconnect will now be configured.

#logic
Get Updates on the Splunk Community!

Adoption of RUM and APM at Splunk

    Unleash the power of Splunk Observability   Watch Now In this can't miss Tech Talk! The Splunk Growth ...

March Community Office Hours Security Series Uncovered!

Hello Splunk Community! In March, Splunk Community Office Hours spotlighted our fabulous Splunk Threat ...

Stay Connected: Your Guide to April Tech Talks, Office Hours, and Webinars!

Take a look below to explore our upcoming Community Office Hours, Tech Talks, and Webinars in April. This post ...