All Apps and Add-ons

DB2 connect error "uniqueKey not found in mappings"


Hello Team,

I am getting this error while running command while i have checked that i have 4.2 driver of MSSQL .
please help me

| dbxquery connection="CloudAssessment" query="select DISTINCT Hostname, cpucount, Operating_System, ram,Landing_Zone, R_Lane, App_Group from [CloudStudio].[dbo].Assessment_MGL where Hostname IS NOT NULL"
| eval cpucount = if(like(cpucount,"\"\""),'',cpucount)
| eval Operating_System = if(like(Operating_System,"\"\""),'',Operating_System)
| eval ram = if(like(ram,"\"\""),'',ram)
| table Hostname, cpucount, Operating_System, ram, Landing_Zone, R_Lane, App_Group
| dbxoutput output="Velostrata_Input"

uniqueKey not found in mappings error

We have checked we have all database fields in database .

Labels (2)


I had the same issue. The uniqueKey has to be the first key you define.

Rebuild your connection with the uniqueKey first (or edit db_outputs.conf) and it should work.

It at least worked for me with an Oracle database.


Try downgrading Splunk DB Connect to version 3.1.4. I had the same error with versions 3.2.0 and 3.3.1.

Get Updates on the Splunk Community!

Streamline Data Ingestion With Deployment Server Essentials

REGISTER NOW!Every day the list of sources Admins are responsible for gets bigger and bigger, often making the ...

Remediate Threats Faster and Simplify Investigations With Splunk Enterprise Security ...

REGISTER NOW!Join us for a Tech Talk around our latest release of Splunk Enterprise Security 7.2! We’ll walk ...

Introduction to Splunk AI

WATCH NOWHow are you using AI in Splunk? Whether you see AI as a threat or opportunity, AI is here to stay. ...