All Apps and Add-ons

DB2 connect error "uniqueKey not found in mappings"

lmjoin115
Explorer

Hello Team,

I am getting this error while running command while i have checked that i have 4.2 driver of MSSQL .
please help me

| dbxquery connection="CloudAssessment" query="select DISTINCT Hostname, cpucount, Operating_System, ram,Landing_Zone, R_Lane, App_Group from [CloudStudio].[dbo].Assessment_MGL where Hostname IS NOT NULL"
| eval cpucount = if(like(cpucount,"\"\""),'',cpucount)
| eval Operating_System = if(like(Operating_System,"\"\""),'',Operating_System)
| eval ram = if(like(ram,"\"\""),'',ram)
| table Hostname, cpucount, Operating_System, ram, Landing_Zone, R_Lane, App_Group
| dbxoutput output="Velostrata_Input"

uniqueKey not found in mappings error

We have checked we have all database fields in database .

Labels (2)

AndySplunks
Communicator

I had the same issue. The uniqueKey has to be the first key you define.

Rebuild your connection with the uniqueKey first (or edit db_outputs.conf) and it should work.

It at least worked for me with an Oracle database.

edgars
Engager

Try downgrading Splunk DB Connect to version 3.1.4. I had the same error with versions 3.2.0 and 3.3.1.

Get Updates on the Splunk Community!

Introducing Ingest Actions: Filter, Mask, Route, Repeat

WATCH NOW Ingest Actions (IA) is the best new way to easily filter, mask and route your data in Splunk® ...

Splunk Forwarders and Forced Time Based Load Balancing

Splunk customers use universal forwarders to collect and send data to Splunk. A universal forwarder can send ...

NEW! Log Views in Splunk Observability Dashboards Gives Context From a Single Page

Today, Splunk Observability releases log views, a new feature for users to add their logs data from Splunk Log ...