All Apps and Add-ons

DB-Connect version 3.1 indexing issue

New Member

I am facing issues with indexing after the installation of Splunk dbconnect. Below are the details about the environment.

Splunk environment : Distributed with single search head and clustered indexers.
DB-Connect version : 3.1.1
Splunk version : 6.4.4
Server OS: Windows 2k12
Logs collected are from Microsoft SQL-Server database.

Current state:
DB-Connect is installed on search-head server and the queries are getting executed as expected in the SQL-Explorer.

Issue :
Neither the “dbx” logs nor the “inputs” are getting indexed. How do I forward these to the indexers so that I can search using search and reporting app.
Also I have not installed forwarder on search-head. Do I need to do it or does dbconnect app internally forward data to the indexers.
Could you please help me in fixing this issue.

0 Karma
1 Solution

Influencer

You don't need to install a Universal Forwarder for sending the DBConnect data to the indexer layer. (every Splunk instance has Forwarding embedded in it)

You should have already an outputs.conf file to send everything from the SH to the indexer layer (at least all your internal logs).

If you don't have that one yet, I would create a blank app named org_all_outputs, then in the local directory, put a outputs.conf and point the SH to send everything to the indexer layer (meaning all your indexers)

https://docs.splunk.com/Documentation/Forwarder/7.0.2/Forwarder/Configureforwardingwithoutputs.conf

View solution in original post

0 Karma

Influencer

You don't need to install a Universal Forwarder for sending the DBConnect data to the indexer layer. (every Splunk instance has Forwarding embedded in it)

You should have already an outputs.conf file to send everything from the SH to the indexer layer (at least all your internal logs).

If you don't have that one yet, I would create a blank app named org_all_outputs, then in the local directory, put a outputs.conf and point the SH to send everything to the indexer layer (meaning all your indexers)

https://docs.splunk.com/Documentation/Forwarder/7.0.2/Forwarder/Configureforwardingwithoutputs.conf

View solution in original post

0 Karma

New Member

Hi,Thank you for the response.I checked "outputs.conf" and see that it is configured properly.

0 Karma

Influencer

Just to be sure, can you do this search and check if your SH internal data is reaching the Indexer layer?

Last 24h:

| tstats count by host

Check if your SH is in the host column please

0 Karma

New Member

The SH name is not there in the host column,which means SH data is not reaching Indexer layer.But,the outputs.conf is configured properly.

0 Karma

Influencer

Could you please show your outputs.conf configuration?

And can you make sure also that your Indexer has an inputs.conf that is opening a receiving port with a [splunktcp:<port>]?

0 Karma

New Member

Output.conf : "Splunk\etc\system\local\outputs.conf" on SH

[tcpout]
defaultGroup = default-autolb-group

[tcpout-server://indexer1:9997]

[tcpout:default-autolb-group]
disabled = false
server = indexer1:9997,indexer2:9997
compressed = true

[tcpout-server://indexer2:9997]

0 Karma

New Member

And also I do not see "inputs.conf" file in the SH "Splunk\etc\apps\splunk_app_db_connect\local"

0 Karma

Influencer

Please follow this link to create your database inputs. Those are the ones who will be sent to your Indexer layer.

http://docs.splunk.com/Documentation/DBX/3.1.2/DeployDBX/Createandmanagedatabaseinputs

0 Karma

Influencer

Are the indexer1 and indexer2 reachable from your SH?

Do you have the [splunktcp:9997] in your inputs.conf on both indexer1 and indexer2?

Can you check on your SH $SPLUNK_HOME/var/log/splunk/splunkd.log for something about "TcpOutputProc - Tcpout Processor ERROR" and give us what it refers?

0 Karma

New Member

Yeah.There is an error Processor error

03-19-2018 01:57:50.449 -0700 ERROR TcpInputProc - Error encountered for connection from src. error:1408F10B:SSL routines:SSL3_GET_RECORD:wrong version number

0 Karma

Influencer

Well then you have to solve that first just to have your internal logs (including dbx ) being sent and properly searched in the indexers layer.

0 Karma

New Member

Thank you.

0 Karma
Don’t Miss Global Splunk
User Groups Week!

Free LIVE events worldwide 2/8-2/12
Connect, learn, and collect rad prizes and swag!