All Apps and Add-ons

Custom fields of a query are not showing up in the Splunk Machine Learning Toolkit.

maane018
New Member

In the search module, I have extracted 2 custom fields for a query and they show up after some time in that module itself. However, custom fields are not present when I put the same query in the Splunk Machine Learning Toolkit.
What can be done to see those 2 custom fields in the toolkit?

0 Karma
1 Solution

cburke_splunk
Splunk Employee
Splunk Employee

Hi maane018,

Field extractions are entities in Splunk that are subject to sharing levels. This means that when you created your field extractions in the Search app namespace they were local to that app namespace by default. If you want another app namespace to see those field extractions you should follow:

https://docs.splunk.com/Documentation/Splunk/7.0.1/Knowledge/Manageknowledgeobjectpermissions

Now, if for some reason you have shared your field extractions with all apps, and MLTK still cannot see it, let's talk some more!

Cory

View solution in original post

cburke_splunk
Splunk Employee
Splunk Employee

Hi maane018,

Field extractions are entities in Splunk that are subject to sharing levels. This means that when you created your field extractions in the Search app namespace they were local to that app namespace by default. If you want another app namespace to see those field extractions you should follow:

https://docs.splunk.com/Documentation/Splunk/7.0.1/Knowledge/Manageknowledgeobjectpermissions

Now, if for some reason you have shared your field extractions with all apps, and MLTK still cannot see it, let's talk some more!

Cory

View solution in original post

maane018
New Member

Hi Cory,

It was the same issue that you mentioned. It worked. Thanks!

0 Karma
.conf21 CFS Extended through 5/20!

Don't miss your chance
to share your Splunk
wisdom in-person or
virtually at .conf21!

Call for Speakers has
been extended through
Thursday, 5/20!