All Apps and Add-ons

Cisco AMP for Endpoints Events Input is not having any input. Stuck at Please wait.

Path Finder

Cisco AMP for Endpoints Events Input is stuck at "Please Wait" for all the tabs, Input, New Input and Configuration.

I can not perform any configuration or Input.

0 Karma


I know its been awhile for this question. I had the same issue.
1. Validate that outbound http is allowed from your splunk server
2. curl -k -X GET -H 'accept:application/json' -H 'content-type:application/json' --compressed -H 'Accept-Encoding:gzip,deflate' -u <THIRD_PARTY_API_KEY>:<API_KEY> ''

If you get a list of computers back then you are good.
Locate under etc\apps\amp4e_events_input\bin\pika\adapters and look for DO_HANDSHAKE = True and change it to False
Restart Splunk


Hey @jet1276,

Please refer this doc and also check if the pre-requisites are met

0 Karma

Path Finder

Hi @deepashri_123,

I have gone through all the details and pre-requisites and all the properties are met.

I have all the details from API, key and Clinet ID. But the only thing is after installing the App I am not getting the Input tab.

0 Karma


Are you using clustered environment or single instance?

0 Karma

Path Finder


It's running on Single instance. And I even tried installing in different versions of splunk. But everywhere I'm getting the same result.

0 Karma
Get Updates on the Splunk Community!

New Cloud Intrusion Detection System Add-on for Splunk

In July 2022 Splunk released the Cloud IDS add-on which expanded Splunk capabilities in security and data ...

Happy CX Day to our Community Superheroes!

Happy 10th Birthday CX Day!What is CX Day? It’s a global celebration recognizing innovation and success in the ...

Check out This Month’s Brand new Splunk Lantern Articles

Splunk Lantern is a customer success center providing advice from Splunk experts on valuable data insights, ...