All Apps and Add-ons

Ciphering services not available with snmp_ta?


I seem to be having issues getting SNMP inputs to work on a new install of Splunk. I already have this exact setup working in other environments, so this has stumped me.

Error in splunkd.log
message from "python /opt/splunk/etc/apps/snmp_ta/bin/" Ciphering services not available snmp_stanza:snmp://cisco:mds9000:test

destination =
do_bulk_get = 1
do_get_subtree = 1
index = snmp_test
ipv6 = 0
object_names =,,,
snmp_mode = attributes
snmp_version = 3
sourcetype = snmp_test1
split_bulk_output = 1
trap_rdns = 0
v3_authKey = ********
v3_authProtocol = usmHMACSHAAuthProtocol
v3_privProtocol = usmAesCfb128Protocol
v3_securityName = ********
v3_privKey = ********
disabled = 0
snmpinterval = 300
interval = 300

As the MIBS are already python compiled in the other envs, I've just copied them over. I'm probably missing something blindingly obvious. But if anyone has any ideas, I would be very grateful.

I've also tried an snmpwalk from the collector server and that seems to run ok.

snmpwalk -v3 -l authPriv -u splunk -a SHA -A "********" -x AES -X "********"

SNMPv2-MIB::sysDescr.0 = STRING: Cisco NX-OS(tm) m9100, Software (m9100-s5ek9-mz), Version 6.2(19), RELEASE SOFTWARE >
Copyright (c) 2002-2013 by Cisco Systems, Inc. Compiled 1/30/2017 23:00:00
SNMPv2-MIB::sysObjectID.0 = OID: SNMPv2-SMI::enterprises.
DISMAN-EVENT-MIB::sysUpTimeInstance = Timeticks: (2288470610) 264 days, 20:51:46.10
SNMPv2-MIB::sysContact.0 = STRING: aname
SNMPv2-MIB::sysName.0 = STRING: aname

Labels (1)
1 Solution


OK.. fixed it. I hadn't installed the pycryto package into /opt/splunk/etc/apps/snmp-ta/bin. DOH!

View solution in original post

0 Karma

New Member

Mind to tell how to install?

0 Karma

New Member

i found solution.

You need to pip install pycryptodome package, and copy out the Cipher folder from the package to /opt/splunk/etc/apps/snmp_ta/bin/Cipher. Initially my snmp_ta is using python version 2, after pasting to bin, you need to change to python version 3 to make it work.



splunk =9.0.2

Hope it helps someone who having the same issue.

0 Karma


OK.. fixed it. I hadn't installed the pycryto package into /opt/splunk/etc/apps/snmp-ta/bin. DOH!

0 Karma


Hi! so how did you install?

0 Karma


also wanna know how did you install it

0 Karma
Get Updates on the Splunk Community!

Data Preparation Made Easy: SPL2 for Edge Processor

By now, you may have heard the exciting news that Edge Processor, the easy-to-use Splunk data preparation tool ...

Introducing Edge Processor: Next Gen Data Transformation

We get it - not only can it take a lot of time, money and resources to get data into Splunk, but it also takes ...

Tips & Tricks When Using Ingest Actions

Tune in to learn about:Large scale architecture when using Ingest ActionsRegEx performance considerations ...