All Apps and Add-ons

Can collectd be used with RHEL 6.9? it works fine with 7.4 but isn't sending data to splunk using the hec token with 6.9.

jlstanley
Path Finder

works fine with RHEL 7.4 but won't gives an error "Token is required","code":2 . it looks like it may be related to version 5.5.2 of the collectd but I need to know if there's a newer version that's possible to use that does work with redhat 6.9.

0 Karma

lukeh
Contributor

Hi,

collectd version 5.6 or higher is required 🙂

I have updated the doco to be clearer on this point.

Cheers,

Luke.

0 Karma

hthiel
Explorer

Hi lukeh,

is it really required

0 Karma

lukeh
Contributor

collectd version 5.6 includes support for the write_http plugin, which is used to send the metrics to the Splunk HTTP Event Collector.

I have not tested collectd below 5.6, but a different method of sending events to Splunk would have to be used.

0 Karma