All Apps and Add-ons

App update broke the app and I can't re-install it

feichinger
Explorer

Hey

I have a single server 8.1.2 deployment on a Windows 2016 server, with the Splunk_TA_windows app installed and that app broke when updating it to 8.1.1

Now it shows with version number "8.1.1R62a79cd" and it's knowledge objects don't seem to take effect.

feichinger_0-1615293097521.png

I tried disabling it, stopping Splunk, removing deleting the folder (had to use takeowner.exe to be able to delete it), starting Splunk and then re-installing the app without issues - but it again shows with version 8.1.1R62a79cd and is not working. I tried this with installing from the app store, as well as downloading the app to a file and install from there.

After a while of it being re-installed, the app management page would show the link to update from this version 8.1.1R62a79cd to version 8.1.1 which acts the same way as updating other apps but it doesn't fix the issue.

What else can I try?

thanks

Labels (2)
0 Karma

scelikok
Champion

Version 8.1.1R62a79cd Is normal, this is what it has inside Splunk_TA_windows/default/app.conf file.

If this reply helps you an upvote is appreciated.
0 Karma

feichinger
Explorer

then maybe that's where its getting that version number from, but I don't think it supposed to show up like that in the app list.

the fact that it offers to update to 8.1.1 suggests that it's in a faulty state

feichinger_0-1616591171326.png

 

0 Karma

ChuckM
New Member

I am having the same issue, has anyone found a fix for this?

0 Karma

ryansaunders
Explorer

I'm seeing the same behavior with the version number showing as 8.1.1R62a79cd, though the TA still appears to be working normally for me.

I opened a support case about the version number this morning and will post back here if I hear anything.

0 Karma
.conf21 Now Fully Virtual!
Register for FREE Today!

We've made .conf21 totally virtual and totally FREE! Our completely online experience will run from 10/19 through 10/20 with some additional events, too!