All Apps and Add-ons

Amazon Kinesis Modular Input: Why am I getting error "Can't connect to Splunk REST API with the token..." after upgrading the add-on to 0.7.0?

Contributor

I was using Kinesis Moduluar Input to consume 5 Kinesis queue on my Splunk 6.2 environment for last month and it was woking fine. Today I just upgrade the app and now it's giving me error like:

02-09-2015 17:06:26.272 +0000 ERROR ExecProcessor - message from "python /opt/splunk/etc/apps/kinesis_ta/bin/kinesis.py" Can't connect to Splunk REST API with the token [Splunk 2ScoSY4vwensp1G1PmP1O_rw2tQO3qM_7xk0yf4Amju2CSQG2aXUutgt6x9ldqvF44CLNze0uc7UHrKANy^PxsV6WasDmaZQJx_BLomQxVFI9WgPUJ_A0hApwES], either the token is invalid or SplunkD has exited : No appropriate protocol (protocol is disabled or cipher suites are inappropriate)

Any idea how to solve it?

0 Karma

Ultra Champion

Update : try the version here : http://damiendallimore.github.io/ (before I release it and screw up Splunkbase again 🙂 )

I weeded out the TLS bug / SDK incompatibilitys issues

0 Karma

Ultra Champion

I rolled back the newest release , found a bug.

0 Karma