All Apps and Add-ons
Highlighted

Add-on for JIRA: Do config.ini and jira.conf need to have the same set of credentials to connect to JIRA server?

Explorer

I just want to confirm if both config.ini and jira.conf need to have the same set of credentials to connect to Jira server. I still cannot get the add-on to work and return results from my Jira server.

In my current config, these set of parameters have been set to match

config.ini ==== jira.conf
hostname ==== server
username ==== username
password ==== password
jiraport ==== port
jira
protocol ==== protocol

Is this correct?

0 Karma
Highlighted

Re: Add-on for JIRA: Do config.ini and jira.conf need to have the same set of credentials to connect to JIRA server?

Splunk Employee
Splunk Employee

You'll set your server info for:
- config.ini: If you want to do live query with | jira command.
- inputs.conf: If you want to index your jira data

There is no server info in jira.conf

0 Karma
Highlighted

Re: Add-on for JIRA: Do config.ini and jira.conf need to have the same set of credentials to connect to JIRA server?

Explorer

Ok, I have set up both config.ini and inputs.conf with my server info. Running | jira filters in Splunk though returns nothing. Querying the API from my indexers and my search-heads returns results successfully:

curl -u <jira_username> "https://jira.gamesys.co.uk/rest/api/2/filter/favourite?expand"
Enter host password for user '<jira_username>':
[{"self":"https://jira.gamesys.co.uk/rest/api/2/filter/16852","id":"16852","name":................

My conf files look like this:

config.ini

[jira]
hostname = jira.gamesys.co.uk
username = <jira_username>
password = <jira_password>
jira_protocol = https
jira_port = 443

inputs.conf

[jira]
sourcetype = jira
index=jira
interval = 60
server = jira.gamesys.co.uk
protocol = https
port = 443
jql = issueType in (epic, story)
username = <jira_username>
password = <jira_password>

Any idea what the issue could be?

0 Karma