Why is the Splunk email Alert link not accessible?


Hi Team,

We are on Splunk 7.1.6 Version, I have configured Splunk Alert to send email and we are getting link to the Alert but the link is not accessible. I see the link has Search Head hostname, when I replace it with Search Head IP I am able to access the link.

How can I change the setting so that I get Alert link using IP instead of hostname ?

Eg-Hostname: http://sh-46177-3-1732:8000/splunk/splunkdownAlert ----- this is not working
When I replace to IP, it works
Eg: ------ This works


After making this change, all Jobs went into Queue for almost 12hrs and when I reverted back I see all jobs triggered back and splunk got hanged. I have went a head and restarted Search Head. Now I don't see triggered jobs in UI but the jobs are getting triggered. How can I fix this ?

0 Karma

Super Champion

Hi @pkumar9610,
Go to Settings>>Server settings>>Email settings
In Link hostname add
and click Save.
It will change your hostname with ip address.

0 Karma


After making this change, all the jobs went into the queue and non of them got triggered for almost 12hours. When I reverted back they all got hanged and search is not responding. So I have restart search heads, no search is accessible but non of the Jobs (Alerts, Reports) are getting triggered.

Can you please help how to fix this ASAP, this is impacting all the customers.

0 Karma
Get Updates on the Splunk Community!

Splunk Security Content for Threat Detection & Response, Q1 Roundup

Join Principal Threat Researcher, Michael Haag, as he walks through:An introduction to the Splunk Threat ...

Splunk Life | Happy Pride Month!

Happy Pride Month, Splunk Community! 🌈 In the United States, as well as many countries around the ...

SplunkTrust | Where Are They Now - Michael Uschmann

The Background Five years ago, Splunk published several videos showcasing members of the SplunkTrust to share ...