<?xml version="1.0" encoding="UTF-8"?>
<rss xmlns:content="http://purl.org/rss/1.0/modules/content/" xmlns:dc="http://purl.org/dc/elements/1.1/" xmlns:rdf="http://www.w3.org/1999/02/22-rdf-syntax-ns#" xmlns:taxo="http://purl.org/rss/1.0/modules/taxonomy/" version="2.0">
  <channel>
    <title>topic Re: [Splunk Content] Xp_cmdshell enablement rule error in content management in Splunk Enterprise Security</title>
    <link>https://community.splunk.com/t5/Splunk-Enterprise-Security/Splunk-Content-Xp-cmdshell-enablement-rule-error-in-content/m-p/755952#M12773</link>
    <description>&lt;P&gt;Hi&amp;nbsp;&lt;a href="https://community.splunk.com/t5/user/viewprofilepage/user-id/262486"&gt;@nooproblems&lt;/a&gt;&amp;nbsp;&lt;/P&gt;&lt;P&gt;It seems there is something odd going on with the response received from the API call to disable the rule, can you open the browser's Developer Console and click the Network tab, then try the disable action and see if you see a non-200 status API call, if you click in the Response tab is there anything which indicates what could be going on?&amp;nbsp;&lt;/P&gt;&lt;P&gt;It could be a coincidence that its since enabling this rule (but not necessarily!) but the output from the API call would be helpful in determining the issue.&lt;/P&gt;&lt;P&gt;&lt;span class="lia-unicode-emoji" title=":glowing_star:"&gt;🌟&lt;/span&gt;&lt;SPAN&gt;&amp;nbsp;&lt;/SPAN&gt;&lt;STRONG&gt;Did this answer help you?&lt;/STRONG&gt;&lt;SPAN&gt;&amp;nbsp;&lt;/SPAN&gt;If so, please consider:&lt;/P&gt;&lt;UL&gt;&lt;LI&gt;Adding karma to show it was useful&lt;/LI&gt;&lt;LI&gt;Marking it as the solution if it resolved your issue&lt;/LI&gt;&lt;LI&gt;Commenting if you need any clarification&lt;/LI&gt;&lt;/UL&gt;&lt;P&gt;Your feedback encourages the volunteers in this community to continue contributing&lt;/P&gt;</description>
    <pubDate>Thu, 27 Nov 2025 22:11:33 GMT</pubDate>
    <dc:creator>livehybrid</dc:creator>
    <dc:date>2025-11-27T22:11:33Z</dc:date>
    <item>
      <title>[Splunk Content] Xp_cmdshell enablement rule error in content management</title>
      <link>https://community.splunk.com/t5/Splunk-Enterprise-Security/Splunk-Content-Xp-cmdshell-enablement-rule-error-in-content/m-p/755946#M12772</link>
      <description>&lt;P&gt;On Splunk ES I’m having an issue with the rule &lt;STRONG&gt;“Windows SQL Server xp_cmdshell Config Change”&lt;/STRONG&gt; (&lt;A class="" href="https://research.splunk.com/endpoint/5eb76fe2-a869-4865-8c4c-8cff424b18b1/" target="_new" rel="noopener"&gt;https://research.splunk.com/endpoint/5eb76fe2-a869-4865-8c4c-8cff424b18b1/&lt;/A&gt;).&lt;BR /&gt;After enabling it, I can no longer disable or delete the rule.&lt;/P&gt;&lt;P&gt;I created a custom rule equivalent to that one with the search:&lt;BR /&gt;index=wineventlog EventCode=15457 "*xp_cmdshell*"&lt;BR /&gt;and it encounters the same issue. Even when I manually run the search&lt;BR /&gt;index=wineventlog EventCode=15457 "*xp_cmdshell*",&lt;BR /&gt;Splunk reports an error. I’m not sure what the underlying issue is. I’m wondering if anyone has encountered this problem before.&lt;/P&gt;&lt;P&gt;Please help me disable or delete this rule, and let me know what the root cause of the issue might be.&lt;/P&gt;&lt;P&gt;&lt;span class="lia-inline-image-display-wrapper lia-image-align-inline" image-alt="nooproblems_0-1764258932428.png" style="width: 400px;"&gt;&lt;img src="https://community.splunk.com/t5/image/serverpage/image-id/40905iE55E385DF1F8BEDB/image-size/medium?v=v2&amp;amp;px=400" role="button" title="nooproblems_0-1764258932428.png" alt="nooproblems_0-1764258932428.png" /&gt;&lt;/span&gt;&lt;/P&gt;&lt;P&gt;&lt;span class="lia-inline-image-display-wrapper lia-image-align-left" image-alt="nooproblems_1-1764258964171.png" style="width: 400px;"&gt;&lt;img src="https://community.splunk.com/t5/image/serverpage/image-id/40906i989D6C4D6325193B/image-size/medium?v=v2&amp;amp;px=400" role="button" title="nooproblems_1-1764258964171.png" alt="nooproblems_1-1764258964171.png" /&gt;&lt;/span&gt;&lt;/P&gt;&lt;P&gt;&amp;nbsp;&lt;/P&gt;&lt;P&gt;&amp;nbsp;&lt;/P&gt;</description>
      <pubDate>Thu, 27 Nov 2025 15:57:20 GMT</pubDate>
      <guid>https://community.splunk.com/t5/Splunk-Enterprise-Security/Splunk-Content-Xp-cmdshell-enablement-rule-error-in-content/m-p/755946#M12772</guid>
      <dc:creator>nooproblems</dc:creator>
      <dc:date>2025-11-27T15:57:20Z</dc:date>
    </item>
    <item>
      <title>Re: [Splunk Content] Xp_cmdshell enablement rule error in content management</title>
      <link>https://community.splunk.com/t5/Splunk-Enterprise-Security/Splunk-Content-Xp-cmdshell-enablement-rule-error-in-content/m-p/755952#M12773</link>
      <description>&lt;P&gt;Hi&amp;nbsp;&lt;a href="https://community.splunk.com/t5/user/viewprofilepage/user-id/262486"&gt;@nooproblems&lt;/a&gt;&amp;nbsp;&lt;/P&gt;&lt;P&gt;It seems there is something odd going on with the response received from the API call to disable the rule, can you open the browser's Developer Console and click the Network tab, then try the disable action and see if you see a non-200 status API call, if you click in the Response tab is there anything which indicates what could be going on?&amp;nbsp;&lt;/P&gt;&lt;P&gt;It could be a coincidence that its since enabling this rule (but not necessarily!) but the output from the API call would be helpful in determining the issue.&lt;/P&gt;&lt;P&gt;&lt;span class="lia-unicode-emoji" title=":glowing_star:"&gt;🌟&lt;/span&gt;&lt;SPAN&gt;&amp;nbsp;&lt;/SPAN&gt;&lt;STRONG&gt;Did this answer help you?&lt;/STRONG&gt;&lt;SPAN&gt;&amp;nbsp;&lt;/SPAN&gt;If so, please consider:&lt;/P&gt;&lt;UL&gt;&lt;LI&gt;Adding karma to show it was useful&lt;/LI&gt;&lt;LI&gt;Marking it as the solution if it resolved your issue&lt;/LI&gt;&lt;LI&gt;Commenting if you need any clarification&lt;/LI&gt;&lt;/UL&gt;&lt;P&gt;Your feedback encourages the volunteers in this community to continue contributing&lt;/P&gt;</description>
      <pubDate>Thu, 27 Nov 2025 22:11:33 GMT</pubDate>
      <guid>https://community.splunk.com/t5/Splunk-Enterprise-Security/Splunk-Content-Xp-cmdshell-enablement-rule-error-in-content/m-p/755952#M12773</guid>
      <dc:creator>livehybrid</dc:creator>
      <dc:date>2025-11-27T22:11:33Z</dc:date>
    </item>
  </channel>
</rss>

