<?xml version="1.0" encoding="UTF-8"?>
<rss xmlns:content="http://purl.org/rss/1.0/modules/content/" xmlns:dc="http://purl.org/dc/elements/1.1/" xmlns:rdf="http://www.w3.org/1999/02/22-rdf-syntax-ns#" xmlns:taxo="http://purl.org/rss/1.0/modules/taxonomy/" version="2.0">
  <channel>
    <title>topic ERROR DistributedBundleReplicationManager - got non-200 response from peer. in Deployment Architecture</title>
    <link>https://community.splunk.com/t5/Deployment-Architecture/ERROR-DistributedBundleReplicationManager-got-non-200-response/m-p/191042#M23546</link>
    <description>&lt;P&gt;Hi,&lt;/P&gt;

&lt;P&gt;Currently, i have upgraded splunk from 6.0.4 to 6.1.1 in our test box.&lt;BR /&gt;
Till then, i am able too the follwoig error log in splunkd.log&lt;/P&gt;

&lt;P&gt;ERROR DistributedBundleReplicationManager - got non-200 response from peer.uri=****, &lt;BR /&gt;
reply="HTTP/1.1 400 Bad Request" response_code=400&lt;/P&gt;

&lt;P&gt;Could someone help to clarify and resolve the above?&lt;/P&gt;

&lt;P&gt;Thanks&lt;BR /&gt;
Jerina&lt;/P&gt;</description>
    <pubDate>Fri, 06 Jun 2014 10:49:30 GMT</pubDate>
    <dc:creator>jerinabeham</dc:creator>
    <dc:date>2014-06-06T10:49:30Z</dc:date>
    <item>
      <title>ERROR DistributedBundleReplicationManager - got non-200 response from peer.</title>
      <link>https://community.splunk.com/t5/Deployment-Architecture/ERROR-DistributedBundleReplicationManager-got-non-200-response/m-p/191042#M23546</link>
      <description>&lt;P&gt;Hi,&lt;/P&gt;

&lt;P&gt;Currently, i have upgraded splunk from 6.0.4 to 6.1.1 in our test box.&lt;BR /&gt;
Till then, i am able too the follwoig error log in splunkd.log&lt;/P&gt;

&lt;P&gt;ERROR DistributedBundleReplicationManager - got non-200 response from peer.uri=****, &lt;BR /&gt;
reply="HTTP/1.1 400 Bad Request" response_code=400&lt;/P&gt;

&lt;P&gt;Could someone help to clarify and resolve the above?&lt;/P&gt;

&lt;P&gt;Thanks&lt;BR /&gt;
Jerina&lt;/P&gt;</description>
      <pubDate>Fri, 06 Jun 2014 10:49:30 GMT</pubDate>
      <guid>https://community.splunk.com/t5/Deployment-Architecture/ERROR-DistributedBundleReplicationManager-got-non-200-response/m-p/191042#M23546</guid>
      <dc:creator>jerinabeham</dc:creator>
      <dc:date>2014-06-06T10:49:30Z</dc:date>
    </item>
    <item>
      <title>Re: ERROR DistributedBundleReplicationManager - got non-200 response from peer.</title>
      <link>https://community.splunk.com/t5/Deployment-Architecture/ERROR-DistributedBundleReplicationManager-got-non-200-response/m-p/191043#M23547</link>
      <description>&lt;P&gt;I got these on old hardware when I upgraded to 6.1.3.  It appears to be a timing issue and storage speed appears to play a role.  Take a look at this thread.&lt;/P&gt;

&lt;P&gt;&lt;A href="http://answers.splunk.com/answers/12666/42-search-head-asynchronous-bundle-replication-error"&gt;http://answers.splunk.com/answers/12666/42-search-head-asynchronous-bundle-replication-error&lt;/A&gt;&lt;/P&gt;</description>
      <pubDate>Fri, 12 Sep 2014 08:59:17 GMT</pubDate>
      <guid>https://community.splunk.com/t5/Deployment-Architecture/ERROR-DistributedBundleReplicationManager-got-non-200-response/m-p/191043#M23547</guid>
      <dc:creator>bkahlerventer</dc:creator>
      <dc:date>2014-09-12T08:59:17Z</dc:date>
    </item>
    <item>
      <title>Re: ERROR DistributedBundleReplicationManager - got non-200 response from peer.</title>
      <link>https://community.splunk.com/t5/Deployment-Architecture/ERROR-DistributedBundleReplicationManager-got-non-200-response/m-p/191044#M23548</link>
      <description>&lt;P&gt;This happens when the search-head is pushing a search bundle that is too large to the indexers.&lt;/P&gt;

&lt;P&gt;The default bundle max size (maxBundleSize) is 1GB&lt;BR /&gt;
and the default http packet size (max_content_length) accepted by splunkd is 800MB &lt;span class="lia-unicode-emoji" title=":disappointed_face:"&gt;😞&lt;/span&gt;&lt;/P&gt;

&lt;P&gt;Therefore :&lt;/P&gt;

&lt;UL&gt;
&lt;LI&gt;when 1024MB&amp;gt; bundle &amp;gt;800MB see an http error from the indexers. "failed_because_BUNDLE_DATA_TRANSMIT_FAILURE" or "ERROR DistributedBundleReplicationManager - got non-200 response from peer"&lt;/LI&gt;
&lt;LI&gt;when the bundle is &amp;gt;1024MB we see a different error, from the search-head.&lt;/LI&gt;
&lt;/UL&gt;

&lt;P&gt;Workarounds :&lt;/P&gt;

&lt;UL&gt;
&lt;LI&gt;RECOMMENDED :reduce the bundle size (trim your lookups, use blacklists in distsearch.conf)&lt;/LI&gt;
&lt;LI&gt;LESS RECOMMENDED : allow larger bundles&lt;/LI&gt;
&lt;/UL&gt;

&lt;P&gt;example : to bump the bundle size to 2GB max&lt;BR /&gt;
on Indexers , edit server.conf (push from cluster master etc/master-apps in a cluster)&lt;/P&gt;

&lt;PRE&gt;&lt;CODE&gt;[httpServer]
max_content_length = 2147483648 
# in bytes =&amp;gt; 2GBdistsearch.conf 
&lt;/CODE&gt;&lt;/PRE&gt;

&lt;P&gt;on Search-head&lt;/P&gt;

&lt;PRE&gt;&lt;CODE&gt;[replicationSettings] 
maxBundleSize= 2097152 
# in MB =&amp;gt; 2GB
&lt;/CODE&gt;&lt;/PRE&gt;</description>
      <pubDate>Tue, 29 Sep 2020 11:38:09 GMT</pubDate>
      <guid>https://community.splunk.com/t5/Deployment-Architecture/ERROR-DistributedBundleReplicationManager-got-non-200-response/m-p/191044#M23548</guid>
      <dc:creator>yannK</dc:creator>
      <dc:date>2020-09-29T11:38:09Z</dc:date>
    </item>
  </channel>
</rss>

